cut-n-paste from pdf to synopsis removes spaces[BUG LOGGED]

I am running Scrivener for Windows Beta 1.6 on Windows 7.
I discovered this unexpected behavior in a project I had just begun;
I duplicated it in your tutorial.
To try it, take your spacewalk info pdf document from the tutorial;
select some text from it; then paste it into the synopsis.
It pastes, but removes spaces between words.

Before I discovered this, I had tried selecting text from a pdf document,
then auto-populating the synopsis with it.
It crashed (Scrivener closed) every time, even with just one word selected.
This happens with the tutorial spacewalk pdf, also.
(Good news: my project opened beautifully afterward,
as though nothing had happened.)

The link below refers to something similar and marks it as [FIXED] in the title.
Either it is not fixed, or perhaps it is not quite the same as what I discovered.

viewtopic.php?f=32&t=8665&start=0

I hope this is helpful.

Thanks. The previous bug was raised regarding highlighting text in the editor and populating the synopsis. I will raise a bug request for PDF text cut and paste to synopsis and auto-populate.
Lee

Maybe this Windows 7 Problem signature info will help.
(To get it, I selected text in your Tutorial’s space_info pdf document
and tried to auto-populate the synopsis with it.)

Problem signature:
Problem Event Name: APPCRASH
Application Name: Scrivener.exe
Application Version: 0.0.0.0
Application Timestamp: 4d464295
Fault Module Name: QtGui4.dll
Fault Module Version: 4.7.0.0
Fault Module Timestamp: 4d4746a6
Exception Code: c0000005
Exception Offset: 001e8961
OS Version: 6.1.7600.2.0.0.768.3
Locale ID: 1033
Additional Information 1: 0a9e
Additional Information 2: 0a9e372d3b4ad19135b953a78882e789
Additional Information 3: 0a9e
Additional Information 4: 0a9e372d3b4ad19135b953a78882e789

(ALSO: In case it makes a difference, when I said cut and paste from pdf to synopsis removes spaces,
I really meant copy and paste.)