Data doesn't exist error

I use scrivener in my Windows laptop, air2 ipad and mini mac and sync those projects using dropbox. Everything was ok until this morning.
I receive continuously:
sync failed.
an error occurred when trying to create a local directory.
Error: The file “data” doesn’t exist. (the file doesn’t exist)

I tried uninstalling ios scrivener and reinstalling - in case some sort of glitch that can be solved like this. No files have been synced and the same error comes up.

The way I work in scrivener was always like this before today.

I prepare a Project in Windows scrivener. (I have multiple projects, school stuff, book notes, Works in progresses etc) Then when sync is complete to dropbox, I ask ios to sync and if the mood strikes open and work the Project in mac mini. My main tools are win laptop and ios ipad. When I open the Project in mac, it asks to upgrade the Project saying the Project was prepared a previous version (if I recall correctly). But there was no problem opening that Project in ios, whereas now win scrivener asks me to check for updates, yet there is no update pending. So now I cannot work on a Project that I opened and upgraded in mac in win but can in ipad…

Today I created several projects in mac and chaos began. My dropbox sync, but I cannot sync in ipad due to the above mentioned error. I cannot open the file in win as well due to version confusion that is going on at the moment.

So what is the recommendation?
I can temporarily move all folders without data folder under files folder to another place - probably it will then sync in ios. But this is one issue that probably should have been considered and tested for win and ios users when mac version asks for upgrade.
I had previously threw scrivener aside as ios version was very sluggish, but the updates since then solved this matter. So I started using it back. And as scrivener was initially a mac software and I have mini sitting at home for some seldom usage, I decided to buy mac software (after the dark theme came) for scrivener thinking it will be a smooth sync all through my devices. But it leaves a not nice feeling at the moment.
I soooo wanted to benefit the research folder .
Any ideas, feedback on upgrades???

At least a part of the solution? … crivener-3

Also explained here: … patibility

Thanks, I will probably give win beta a try as I liked mac version as well. I am now trying to see if removing all the mac changed projects from dropbox and reinstalling ios will make a change for the sync process. I may also give it a try in mac previous version untill win3 is here.

I am also getting this same error on my iPad4 (running iOS 10.3.3 - no, 11 is not available for my older tablet). In addition, when I went to my file manager on the iPad and looked at my Dropbox folders, I didn’t see the two projects I’d created on my iPad and now want to sync. I also can’t find any Scrivener files on the iPad. I can find two Aeon files (I use iCloud to sync those). But no Scrivener files and I know they’re somewhere on the drive because I can access them without wifi. However, I’m new to iPad, so that may not mean anything.

Apparently, this problem has come up before, but the links in the previous section do not address my situation, nor in the other posts about this issue. Do I have to delete Scrivener from my iPad and possibly lose the two projects I’m trying to sync? How do I get my projects someplace else on my iPad so that I can delete Scrivener and try again?

I’ve got a strange feeling that this has something to do with the iPad’s directory or memory. I tried saving my projects to a different Dropbox folder, per the link here: … g-with-ios (scroll down). Then I tried syncing. I did not get the files missing error.

Nothing, however, showed up in the new Dropbox folder. I reset the Dropbox settings to save in Apps/Scrivener, tried syncing again. Now, on the iPad, I have copies of each of my older projects, one each in Dropbox and one “On my iPad.” In addition, the two newer projects all show up as “On my iPad,” but are not on Dropbox at all.

I powered down and the sync error is gone. But the two sets of files are still there. And the two that are only on the iPad aren’t showing up in any of my Dropbox directories.

“On my iPad” means the project is only kept in the iPad’s internal Scrivener memory, not on Dropbox. To upload it to Dropbox you need to set the target directory in the project screen in Scrivener, under Edit, gear wheel, Dropbox settings.