date format for deadlines

I am trying to set a deadline for my writing project. Although, the default is set for 4 digits for the year. The field will only accept 2 digits. For example, I am trying to give a deadline of May 13, 2018. It will accept 05/13/_ _18 – No matter what I try I can only enter 18. It will only take the 18 and not the 20. But it is clearly looking for 2018.

Not sure what to do. I would appreciate any help to resolve this issue.

Thanks.

I have seen this happen now and then on some systems—never myself unfortunately, so I have no idea how it gets stuck, nor a good way to fix it from the front-end itself. But you should be able to fix it by editing the project settings themselves directly:

  1. From your project, use the File ▸ Show Project in Finder menu command.
  2. Switch back to Scrivener and close your project.
  3. Right-click on the project in the Finder window that opened from step 1, and select the option to compress the file.

This will create a .zip backup right alongside the original. If anything goes wrong you can trash the project and double-click this .zip to extract a pristine copy of it in its current state.

  1. Right-click again and select “Show package contents”.
  2. Open the .scrivx file in a plain text editor (TextEdit is fine)—not Word, or something of that nature.
  3. Search for the word “Deadline”. At the beginning of the line that falls upon, you should see <SessionTarget… In quotes after the word “Deadline” you’ll find your date stamp. It might start off with something like “0018-06-29”, and then some time info. Just fix the year right here, like “2018-06-29”.
  4. Save the file, close it, and then load your project in Scrivener.

The deadline should now be set to a useful date, and hopefully you can type in more than two characters now, if you need to change it!