Dates of snapshots all reverting to today's date

Hi there,

I just noticed this happening… All snapshots, in ALL my projects (some I haven’t even opened in weeks), are currently showing today’s date. Is this a known bug? Is there any way to return them to their original date? It’s not a huge deal, but it IS making it a little confusing.

I did a search but couldn’t find anything relevant to this problem – apologies if it’s already out there.

Cheyenne

That’s very strange, and not something I’ve heard of happening before, let’s see if it’s a display bug or a data bug:

  1. Locate your project in Finder, and make sure it is closed in Scrivener.
  2. Right-click on the project file and select Show Package Contents from the contextual menu.
  3. In this new window, double-click on the Snapshots folder to navigate into it. You’ll find a series of numbered folders, one for each document that has at least one snapshot. Double-click on any of those, and check the file name of the RTFs in there.

Do the RTF filenames look correct? Next, open the XML file in a plain-text editor (TextEdit is fine) that exists in each of these folders, which is what stores the date stamp and your internal description of the snapshot, if any. The date stamp in the XML file is the one Scrivener uses to build the snapshot list you see in the software.

Hi Amber,

Thank you for your reply. I followed your steps and can say the RTF filenames look correct, as there’s a variety of dates and times. Same for the info in the XML files.

I assume this means it’s a display bug – if so, do you have any recommendations of where I go from here?

This problem is ongoing. It seems every time I open Scrivener, it shows me that the time the program opened (exact date and time) is the time of EVERY snapshot throughout the entire project (or indeed, any Scrivener project).

Thanks for your help!

-Cheyenne

Okay! It’s good the dates are all normal in the files themselves. The two things I would check are:

  • Is your system clock correct? Try to sync with the time servers if you can, in system preferences.
  • Are you using a strange date stamp format? There is a bit of a bug in the Mac system in that it allows one to create date stamps that end up breaking all over the place. I’ve experienced this myself as I use an odd system of year + day-of-year instead of months and days, and while the system will let me create a date stamp like that, and it will work here and there, sometimes it malfunctions and makes a huge mess in programs that use date fields. So if you have something unusual, try setting it back to a standard format.

Other than that, I’d just do the typical reboot to flush out all temporary caches and such and get a fresh start for the system.

Hi again,

So this issue of snapshots all reverting to the current day’s date sorted itself out before, but it’s happened again and I have to think its a definite bug.

My system clock is absolutely correct.

And no, I’m not using any strange date stamp format. I changed nothing in my system, but one day opened Scrivener, and all of a sudden, all my snapshots for my current project said that day’s date. And the next day, when I opened it, they all said THAT day. Currently, of course, they all say today’s date, the 23rd.

This is a REAL downer as I like to keep track of when certain versions were recorded.

Has anyone else had this issue, or have any other suggestions?

And is there any easy way to see if any programs have strange date stamp formats across the whole system that might be the root cause? I can’t recall ever changing an app (I have changed my personal blog to show the date as UK (date/month/year) as opposed to the USA format, but this was an online change, not one done on my computer.

I’d appreciate any suggestions! Thanks.

There has been one, maybe two, software updates since you posted this thread. So the first thing I’d do is make sure you are running the latest version your OS X can handle, or 2.7.1 if you purchased from Apple. I can’t think of anything that changed in either of those that might have changed something with how snapshots are displayed in the list, but it’s worth a check.

I’m running the most recent version, 2.7, though not sure what you mean “2.7.1. if you purchased from Apple”. I purchased directly from the website I think, ages ago when I first purchased Scrivener. Does that mean if you purchased from Apple you have access to an update that others don’t?

That aside (sorry for my ignorance)… are there any other suggestions?

Interesting thing is, TODAY I’ve just opened Scrivener for the first time and looked at a few different chapters in my manuscript, and all the dates for snapshots currently say YESTERDAY’s date – this is the first time this has happened since the date started reverting to the current day, the weekend before last.

Experience tells me this means that from now on (until the next mishap), it will begin saving the date as normal. I just took a snapshot, and it saved as 24 Nov, still showing all previous snapshots as 23 Nov. So this is interesting… though I’m not sure it helps in resolving the matter.

Thanks for reading.

Can I make a wild guess — and I’m happy for Ioa to correct me if I’m wrong in my wild-guessness — but have you by any chance been doing a Cmd-S at the points where the snapshot dates change, thereby actually forking the project, and if so, would that change the dates on the snapshots to the dates on which the project was forked?

As I say, it’s a wild guess … I’ve never experienced it, but then I don’t think I’ve ever forked a project, so I don’t know what happens.

Mr X

Hi Mr X,

Thanks for your guess. I had to look up “forking” in the manual as I’d never heard that phrase before. Does it mean making a copy of a project, and then saving the copy separately? If so, I haven’t done that with this. I think I did it with a previous project, but I’ve not touched that one while experiencing (or just prior to) this current issue.

As for the forking thing, the manual says that “File>Save AS” is how to fork, not simply Cmd-S, which is just saving the current project. I Cmd-S all the time to save the current project! But I’ve never done “Save As” so I have a feeling that’s not it.

Thank you for taking a stab, though!

Yes, but it’s not a very exciting update. :slight_smile: All it did was fix one (critical) problem relating to sandboxing, which we do not use for the direct-sale version in the first place. We only use it for the App Store version because it’s a part of the rules for inclusion in that store.

Using Save-As should not modify any snapshot dates, nothing should be, in fact, which is what makes this a weird bug. The snapshot filenames and XML files that describe them, on the disk, look fine—it’s just displaying the wrong dates in the user interface for some reason, and in a way that impacts all projects.

I would try, when you get the time to do so, rebooting your Mac and holding down the Shift key when you hear the startup chime. You can let go once the progress bar comes up, and then proceed to log in normally. This is safe boot, nothing but Finder will be running and all deeper modifications to how the Mac works (such as how an antivirus program might do) will be disabled. In other words: it will be just you, Scrivener, and stock OS X. Under those conditions does the problem vanish?

If so, try a normal reboot and check again, if the problem is back, odds are high it is one of those things I mentioned: something installed on the Mac or running in the background on a daily basis.

I did think of one thing that might help: given that is purely a display bug, the underlying datestamp info might be correct even if they appear incorrect. That could become useful with sort. If you sort your snapshot list by the date column (click in the header bar to do so), do snapshots appear in the correct order? If so, that should at least give you a chronology, even if you can’t readily see when you wrote a second draft, it at least will not precede the first draft snapshot.

Ahh, okay, thanks for that re: the update!

Frustratingly, last night I discovered that somehow, randomly, while I was working, all the snapshot dates again reverted to the current day. So this morning, they all say 24 Nov.

As far as I can tell, the snapshots have all remained in the same order. When I click on the date, they all stay the same, and they all still look to be in the right order chronologically, so that’s okay. It’s just harder to tell at a glance what each one is.

I tried restarting in safe mode, but that didn’t make any difference that I can tell.

At this point it seems the only work-around for me is to meticulously name each snapshot, but I take rather a lot so this is a bit of a pain. But it seems like a unique issue so I’ll do this for now and report back if I find anything that seems to be related.

Thanks for your suggestions!

Yeah, I would expect that given the nature of the bug, the “dates” will keep changing periodically. It is a pretty unique bug though, I don’t think I’ve ever encountered it before—it might just go away the next time you upgrade OS X, since as I might have mentioned before, we just grab a date off the disk and ask OS X to display it according to your system localisation settings.

One thing that will help should you choose to name them manually: when you double-click into the snapshot title field to name it, the Edit/Insert/Current Date & Time command (Shift-Opt-Cmd-D) can be used here. Unfortunately that can’t be enabled for the dialogue box, if you name it up front with Documents/Snapshots/Take Snapshot with Title, though if you use a text expansion utility (like Typinator or TextExpander) you can insert dates wherever you want on the Mac.

I have sad, frustrating tidings.

This “bug” has not gone away. I’ve updated my OS several times since it originally appeared, and now, with Scrivener 3 (updated on 2 Macs), it persists, in every single one of my projects.

The snapshot date still reverts to today’s date. Even worse, the content of each individual snapshot is exactly the same – showing the most recent content, i.e. what’s in the editor.

I’m still titling each snapshot with the date and time of the snapshot. I use these a LOT. Like, probably more than one is supposed to. Essentially, every time I make changes to a scene, I take a snapshot so I can always roll back to previous versions.

This would still work okay, despite the fact that it irks me to see today’s same date listed over and over when I look at snapshots, but if the content of each individual snapshot was still correct, I could overlook it.

In the past, you suggested that I:

  1. Right-click on the project in Finder and select Show Package Contents.
  2. Drag the “Snapshots” folder to a safe location like ~/Documents.
  3. Now reload the project.

And this would effectively clear out all my snapshots so I could “start fresh” and see if this worked. However, I’ve done this numerous times, and the bug always returns. Sometimes it might keep snapshot dates & content correctly for a few days/weeks, but it always goes wrong eventually. I’ve tried it a handful of times.

So, as it currently stands, even in High Sierra, using Scrivener 3, even in newer projects, all my snapshots always shows the current date, and all the snapshot content ONLY shows the current content of that file (what’s currently in the editor; the most recent version). So it seems like none of my previous snapshots/versions of scenes are being stored, or if they are, Scrivener isn’t retrieving them.

Does anyone have any further suggestions? This problem has been ongoing for 2 years now :frowning: It seems like it must just be me, if no one else has reported it, and I’m fine with being a weirdo, LOL, I just wish I had some concept of how to fix this.

And yes, my computer’s date and time are still correct… :-/

Any other ideas? I’m so frustrated :frowning: Thanks.

Bumping. Anyone? :frowning:

I uninstalled and reinstalled Scrivener 3, deleted all my snapshots, and even started a brand new project yesterday.

As of today, the snapshot I took in the new project yesterday show today’s date and the time I opened Scrivener, a few minutes ago. And rather than the way the snapshot appeared yesterday, it’s only showing the current version in the editor.

This has happened on two separate MacBooks that aren’t not linked in any way (apart from the fact that the Scrivener Projects are stored in Dropbox).

I realise this may be a very specific problem to me, but it’s happening over and over. I have no other known issues with either of my MacBooks. The newer of the two I didn’t even own when all of this first started a few years back.

I am going slowly crazy with this. Snapshots are a huge part of what makes Scrivener valuable to me :frowning: Any ideas would be welcome!! Thanks.

Would it be possible to send a live example of this in in v3 format to our support address? As I recall the problem was visual in nature—the project was fine, but something about the data was causing it to display incorrectly.

And yeah, unfortunately I do think you are the only person that has this problem! That doesn’t mean we don’t want to fix it of course, but it does mean we don’t have much data on it.

I certainly can. What do you mean by “live example”? Sorry, I may need the steps spelled out a bit :blush:

Also, I just checked under metadata on my various projects and they all say today’s date and the time I opened the project today as both the “created” time and “last modified.” Which is really maddening because it means I can’t track the last changes I’ve made and be certain of times. Agh.

Yes, please if you could let me know how to go about this, I will! Thanks!

Just a sample project that shows the error every time you open it up—or if not any instructions necessary to make the error happen once it is opened. To attach a project to an email or via the contact form, use the File/Back Up/Back Up To… menu command with the zip compression option enabled.

Great, thanks. I’ve done so and just sent it to the support email address.