Default font bug

I set all fonts in
Tool->Options->Appearance->Fonts
My case are: Tahoma,Verdana, …

I change all ‘Courier’ to ‘Verdana’ in file scriptformat.xml (in settings folder by every project)

I killed ‘Courier’ in all places.

but

I have ‘Courier New 12’ as default for any ‘New Text’ !!!
it is not all.
I change ‘Courier’ to ‘Verdana’ by hand every time by typewriting and WHEN I OPEN THIS FILE (RTF or was exported) in MS WORD - I have opened document with ‘Courier’.

I can kill Courier by editing in Notepad/AkelPad by hand in RTF files from folder ‘File’.
f.ex.:
every RTF file has (was created by Scrivener):
{\rtf1\ansi\ansicpg1252\deff0
{\fonttbl{\f0\fmodern\fprq2 Courier New;}{\f1\fmodern\fprq2 Verdana;}}

I change Courier to Verdana in only this way

P.S. about 0.29

  • bug with downloading Aspell dict for any lang - nothing doing after keypress - ‘download’
  • bug with saving settings: Scrivener doesn’t save customized toolbar settings. It lost after re-instal and load saved settings.

P.P.S.
How can I make translate user interface to my language (russian, ukrainian)

Best regards.

P.P.P.S

  • Scrivener gives name by Backup: projectname [2011_08_24_07_37_41]
    and file has its name: projectname 2011_08_24_07_37_41
    (blank space after projectname and underline in end).
    Remove this blanspace and underline in the end. Why Scrivener doesn’t have feature to save my favourite mask - I must set it each time when I make backup

  • How can I make ‘go to the next line’ in ‘Synopsis’ window. I can do it only in xx_synopsis.TXT file in DOCs folder.

  • In mode: View group’s subdocuments as scrivenings
    Scrivener doesn’t get NAME of each subdocument. I think this settings must be in Options for this View and for EXPORTs
    f.ex.
    Now:


text of 1-st document

text of 2-nd document

I’d like to see this:

Name of 1-st document
text of 1-st document

Hi,

To change the default text for new documents, go to Tools>Options… and click the Editor tab, then set the font there. (Click the “A” button in the format bar above the preview window to open the fonts panel.) This will affect new documents; you can select existing documents in the binder and use Documents>Convert>Formatting to Default Text Style to change older ones to match your new default settings.

I’m not quite clear what you’re doing here. If you’re using the compile feature, then make sure that in the Formatting options of compile, the text isn’t set to Courier–that or Courier New I believe is the default for the standard novel format, for instance. Using the File>Export command should just make a copy of the selected document and should of course use whatever font you’ve set, so that would be a bug, but I’m not able to reproduce it. Could you explain step by step what you’re doing that’s getting this result?

Noted, thanks for catching this.

There isn’t a way to save the toolbar settings at the moment, no, but this isn’t a bug. Saving settings from the Options panel will save all your global options that you set in that panel, and some other settings, like compile settings or templates, can also be saved and won’t be affected when you uninstall or reinstall. The toolbars should also not be affected if you just upgrade (install over the existing installation) rather than uninstalling first, so most of this time this won’t be that big an issue. Now that the auto-updater has been added back in, using Help>Check for Updates… and upgrading from there will be the easiest and most common way of installing the latest version, and your settings won’t change in the process.

Localizing the program is something that Lee would very much like to do, and he’s been coding with that in mind, so hopefully after 1.0 and initial updates are out, he’ll have a word on the possibility of doing some translations.

This is a known issue, so it’s on Lee’s list to fix. Likewise having the backup dialogue remember your settings.

Open Tools>Options… and under the Navigation tab, deselect the checkbox for “Return ends editing”; you’ll then be able to use the return key to add a new line.

This option will be coming in a 1.x update, along with a smoother Scrivenings view as a whole. The name in the editor header will also change to reflect your cursor position, so instead of just saying “Multiple Selection” or the name of the selected container, the editor header will also provide the name of the current document in that selection.

Very thanks.

About compile and fonts.

I change Courier to Verdana as you say. Thanks. It is working in Scrivener.

but small bug is in compiling.
Verdana is default font, and Scrivener sets Verdana for every new text. In editing mode all is correct.
In RTF files, all is correct. No any Courier.

When I compile - I get Courier in FIRST line only for RUSSIAN text. (second and … are verdana)
See New project and New.doc file in its folder: rghost.net/19201051
See:
All font of all are Verdana in Scrivener.
In compiled file (New.doc) every first line of russian of text are Courier.

P.S.
small
When I backup my project, Scrivener makes in %temp% folder {… some md5 …}.
This folder is mirror of working project.
Scrivener doesn’t delete this folder after closing.
I think Scrivener must clear all data in TEMP folder. This will maintain the confidentiality of

Very thanks.