Default font for bulleted text - how?

I use Optima 13pt as default font in Scrivener. However, when I insert a list with bullets by pressing OPTION-TAB (which I do very often during the development process, because it’s so handy), the font changes invariably to Lucia Grande 13pt. :imp:

Why? :open_mouth:

And is there a way to change this behaviour? :question:

Any hints welcome.

Alas, that is a known Apple bug, most likely. Note the references to “waiting for Leopard”? Yeah. I’d say wait for Snow Leopard, but I’ve lost my optimism in terms of Apple fixing their text system bugs.

I happened to notice yesterday that in Journler, it works as it should. I use there Optima 12pt as default font, and when I enter OPTION-TAB, the bullet comes, but I still write in Optima 12pt.

So, it might be an Apple bug, but Phil Dow seems to have found a work-around. Maybe he is willing to share it? 8)

Funny, because I just tried it in Journler and it had exactly the same problem. :slight_smile:

My guess is that you didn’t do a fair test, that you tried them in different situations. The bug is rather specific - it only happens if you insert a bullet point without any existing text.

So, if you tried in Scrivener to insert a bullet point in an empty document, you would have seen it revert to the default system font.
Then, if you tried in Journler after typing some text and then inserting a bullet, you would see the bulleted text use the same font as you had been typing in.

Try it the other way around and you would think that the bug is in Journler and not in Scrivener - try inserting a bullet in this way in Journler in an entry with no text.

All the best,
Keith

Now I am even more confused. :open_mouth:

What I did before was: I created a new document in Scrivener / a new entry in Journler. I wrote a line of normal text. I pressed return. I pressed Option-Tab.

This is a structure I use very often during the development process. For example:
List of main characters:

  • John Hero
  • Brad Villain
  • Sweet Lovey
  • etc.

In Journler, what I get is: The first line of normal text is in Optima 12pt. And the line with the bullet is also in Optima 12pt.

In Scrivener, what I get is: The first line of normal text is in Optima 13pt (my default font). And the line with the bullet comes in Lucida Grande 13pt.

But - when I do as suggested, create a new, empty entry in Journler and start with Option-Tab, I get Helvetica 12pt!!

So, there is certainly a bug. But - at least on my computer (still Tiger) - there is a different behaviour.

I didn’t mention this to say something negative about Scrivener, far from that. I would be happy if I could just influence the bug in a way that I’d get Optima every time I create a bullet list… because Lucida Grande is not exactly a font I like.

OK, now I read the other the thread. Seems there is not much hope except to hope for a new OS version…

:cry:

I’ve only tested on Leopard - on Leopard the font stays the same in Scrivener when you create a bullet unless it’s on the first line. So it looks like the fixed a tiny bit of it but left the rest broken. Oh well.

That’s good news. If the bug is restricted on empty documents/first lines, I can easily live with it.

I will go Leopard soon anyway. The software lies beside me; as soon as I’m through with the editorial process of my current novel, there will be update-day…