default to scrivenings mode

I never, ever, want document mode. Is it possible to make scrivenings the default?

One of the differences between a folder and a document group (a document with children) is that when you click on a document group by default it goes to single document view. When you click on a folder, it defaults to group view (Scrivenings, or Corkboard or Outliner, whichever you used last for that folder).

(You can’t of course click on a single document and automatically get the scrivenings view of the enclosing folder, unless you’re already in a scrivening.)

So the first thing is either to make everything with children a folder using right-click Convert to folder OR you tell Scrivener to treat all your document groups as folders (this doesn’t change the icon, just the vi3ew behaviour). Preferences > Behaviours > Treat all documents with subdocuments as folders.

All you document groups will now show the scrivening (or cork board or outline) when you click on them.

But, they’ll still remember the last group view, so if you last looked an outline / corkboard, then that’s what it will show when you click on another folder.

To stop that (for both folders and document groups), highlight them and Navigate > Editor > Lock Group View Mode (ie it applies to selected folders, it’s not a global setting).

E.g. click on Folder A and you get a scrivening. Lock the group view and you’ll see a padlock appear in the group view panel in the tool bar.

Now click on Folder B and change it to outline mode, then click back on Folder A. Without Lock Group View, Folder A would be in Outline mode as well. When it’s locked it will still be in scrivenings mode. You can of course still look at it in outline — but that will then be the mode that’s remembered.

HTH.

Not true. Quite often I click on a folder with children and it opens in document view, generally empty. It happened a few minutes ago.

If you have the aforementioned option enabled, so that everything in the binder that is a group acts like a group, then the only two things that could cause a group to open in single document mode are:

  1. That’s the mode you set the split to. There are two splits—so maybe you cleared one and not the other.
  2. At some point in the past you locked that group’s view mode to single document. Right-click on the header bar and make sure that option isn’t checked off.

If you previously looked at it in single document mode then of course it will – it remembers the last view on the assumption that’s what you want next time. If you want it always to open in Scrivenings the next time then follow the steps I gave. Did you try them?

I don’t think I ever set a folder to document view on purpose, not once in 5 years, and I’ve locked the editor exactly once.

The explanations above simply don’t hold water. Not at my machine.

Please do let us know what steps we need to take in order to see the behaviour as you describe. None of us have ever seen it work that way, and the software isn’t programmed to work that way in a general sense—so it’ll take something a little out of the ordinary I’m sure, some clue we’re all missing.

I can’t tell you what steps reproduce it — it’s random — but there’s ZERO doubt it occurs, and not for any of the reasons mentioned above. It happens for folders (no surprise or complaint if it happens for files), and I never, ever select document view on purpose. Nor do I split the Editor.

Like a lot of other things, I’ll just live with it.

:open_mouth:
Why raise a question in here if you are not interested in the answer? :question:

Possible you hit CMD 1 at some point (toggling between document and scrivenings)? Know I have done that when overreaching for CMD Q or CMD W.

Q and W are nowhere near 1:


The plot gets thinner.

Thanks for adding the Navigate/Editor/Lock Group View Mode option.

The problem was real, and this is a great fix.

If the problem is real, could you please tell us how to reproduce it? We have not had one single other report of this, and I’ve never seen it myself, either, despite working in Scrivener day in and day out. The only thing that will cause Scrivener to open a group in single document mode is if you have switched to single document mode for groups at some point (e.g. by clicking on the scrivenings mode icon when its already in scrivenings mode, which turns it off).

All the best,
Keith

I can’t reproduce it at will, and I just noticed the “fix” — lock group mode — apparently applies to single documents. Nor can I select my folders and apply it all at once. Bummer.

Does that mean that if you click back and forth between the same two things in the binder, with no actions taken in between, a certain percentage of the time something different happens than otherwise? Or if the behaviour remains stable (if undesired), does that stable condition persist after reloading the software?

I have no information on how to reproduce the problem. None.

I do know a few things:

  1. I never, ever set the view to document mode; I can’t imagine why anyone needs it; I never will
  2. I don’t use outline view
  3. I rarely split the screen; if I do, it’s usually an accident
  4. I haven’t set the “treat all containers as folders” option, but I’m talking about folders; I have no file containers
  5. at random, I click on a folder and get document mode; it’s not a huge deal, but annoying.
  6. #5 hasn’t happened in a few weeks until today
  7. I thought I could prevent it with the “lock group mode” option, but it seems to apply only to individual documents
  8. I tried selecting all my folders (collapse to current level, etc.) and locking group mode to all of them; that didn’t work

You probably shouldn’t worry about it. I’m sure you have bigger fish to fry.