Delay Write error - big one

I’m not sure this is a Scrivener issue but thought I’d mention it (last stable release NOT beta)
I’d closed Scrivener for the night then about 5 minutes later decided to change a couple of sentences
I began making the small changes, Scrivener froze.
I waited about a minute tried again, but still frozen.
I tried to close normally NOTHING
I CTRL>ALT>DEL and got it to close but got this error notice (see screengrab)

the notice kept popping up and I could not shut down the computer normally; had to do a hard reboot

In restart, I got a very long CHK DSK which found errors in (I’m pretty sure this was the number-- 853_icImage)

Long story short short, when the system finally pulled up my entire D drive showed up BLANK. In fact, the computer wanted to know if I wanted to format drive!!!

My BF-- who fortunately knows hardware-- unhooked it (It’s an internal drive) and using different cables hooked it up to another XP system. That system found many more errors but fixed them (don’t ask me how) and he was able to see my drive and copy ALL my stuff to a clean drive

Meantime, since I had a backup that was only minutes old – while he was recovering all my data in one computer – I was pulling up my Scrivener project backup in my own system onto another drive. Good news is that the project pulled up fine I’d only lost two sentences

Using an image viewer, I looked in the Scrivener folder (FROM MY LAST BACKUP before the crash) Files>Docs folder where the 853_icImage was

There must have been AT LEAST 40 duplicates of that image (with different numbers) and to top it off, it was not a recent image.
And it is not the only one. There are so many duplicates I don’t know what to think.

  1. could that have caused the freeze/crash/Delayed Write Error?
  2. can I delete some of them? if so which ones?

BTW:I am not on a network

Oh, yea, since Tom was able to recover the corrupted project, I can email you any files that may help you figure out this issue. (not that I would go back to writing in there)
PS screengrab example of the duplicates.
I have one that has 3X as many
Help! :question:

delay write.jpg

Hello? anyone there. any help on this?
Serious issue
Would it be best to email tech support on this

Thanks, I’ve found the bug and it should be fixed for the next beta. The images in your example are all synopsis images for a number of different files, maybe from having duplicated documents over time. That’s normal, and part of the problem could be just that you don’t have the synopsis image displayed, so you didn’t realize the image is being copied. There does appear to be a bug though where the synopsis images are not getting properly deleted when an item is emptied from the trash, which could have added to the build up.

You can safely delete them; all that will happen is that the associated documents will no longer have that image appearing in the synopsis, but I assume they’re all currently set to show the text synopsis anyway, or you’d have noticed that the images are there. If there is one particular file where you want it, it’s probably still easiest to just save one copy of the file outside of the project, delete all of the duplicates, and then open the project and drag your image back into the one synopsis where it’s supposed to be.

It’s very unlikely the duplicated images affected the crash, which sounds much more like a hard drive failure.

Yeah, the duplicated images wouldn’t have caused that error. I think it was the cables, as the drive was put into another computer and I was able to retrieve every thing
Still the dupes are puzzling. One image has over 40 dupes.
In just that one project, most images have at least one dupe, most have much more

I’ll go ahead and delete when i have some time, there are so many in each project

One more thing
some are jpg some and png

which one do I leave?

I think the beta 1.7.03 did something to the Scrivener project which caused a cross-link

Since the issue listed in my earlier post caused a corruption of my D drive I used my back up (on C) and created another project on E

I reformatted D drive

then tried to copy the project FROM C to a reformatted D

as you can see from the screengrabs attached got read write errors yet again
NOTE that this was a Scrivener file that was NEVER on the corrupted D drive but a back-up on my C drive
I went into the Scrivener doc folder and with an image viewer saw had 96 duplicates of the same image, 22 dupes of yet another image, and so forth.

I deleted every single one of the 96 images, (left the other dupes alone for now as they were not as as excessive )

Opened the project in the NON-BETA Scrivener, and saw that there was (naturally ) one image missing,
I dragged in a copy from a non-Scrivener folder, closed. the reopened in the NON-BETA Scrivener. No issues
I then was able to copy the Scrivener project to my reformatted D drive

I have to surmise that the issue is a Scrivener one (don’t know if you call it a database), and everything else I had on that drive (including other Scrivener projects) copied smoothly
new error.jpg
new error2.jpg