Delete key in the editor

At first I took this to be a feature, but the behavior (which follows) seemed to go away at one point, only to now return. Perhaps it’s just interimitent.

When using the delete key to correct, rather than stopping at the spaces between words it tends to consume them. For instance the following three words.

I’ve simulated the cursor there. If you hit the delete key the editor will naturally enough delete that last ‘l’. Hit it again and away goes the second ‘l’. Once more and you’re left only with the ‘b’ from the word ‘ball’. So far so good.

No problem. Here’s where the glitch comes in. Hit the back space again and instead of just deleting the ‘b’, Scrivener deletes both the ‘b’ and the space which proceeds it. So you’re left with this:

This is not expected behavior. Every other editor on the planet (that I know of) would leave you with this:

…where the red underscore represents the expected space.

As I said, I at first took this for a quirk of Scrivener (one which minimally should be optional, if indeed it’s intentional) but which seemed to go away at some point, so that the editor behaved as expected, as all editors behave.

To be clear: this is not nitpicking. Someone who types 70+ wpm does so on auto-pilot. As such, this behavior slows down the typing by a magnitude as you hit the delete key, start retyping the world only to discover you adding to the previous word, thus:

So you have to correct two words now. It is behavior that is driving me insane, and I can’t believe other writers haven’t noticed it.

Thanks again for all the great work you guys do. Keep it up!!!

MDMullins

Update: Now the behavior has changed to the normal behavior. This is obviously a bug, so if a moderator would be so kind as to move this to the appropriate sub-forum that would be great.

I have no idea what triggers the behavior nor what makes it go away.

Update 2: I think I’ve isolated the behavior. It happens only if there is text after the text your editing? Can someone confirm this? If you’re typing at the end of document, it won’t do it. But if you insert a paragraph for instance, while you’re typing that paragraph and there is text beyond where you’re typing, the incorrect behavior shows up.

I tried to emulate the said behavior and couldn’t (iPhone 6s). Are you using an external keyboard? Mine does all kinds of weird stuff.

Yes, of course to the external keyboard. It should work either way. No other app has this behavior.

Update: Just tested it with the onscreen keyboard and I could reproduce the bug without Bluetooth keyboard. Try it in an iPad. Font is set to optima, no indents.

I’m trying to see if there’s video screen capture for the iPad so I can capture the behavior. Serious bug.

Here is live video of the bug. (How do you embed video in this forum?)

https://youtu.be/Zxc-zjGiVRw

And here it is closeup:

https://youtu.be/0ji7WbIcoVQ

iPad Air 2, iOS 9.3.4, onscreen kb

Reproduced it deleting word between other words. However, if you place the cursor at the beginning of the word which follows the word you wish to delete, the proper spacing is maintained.

Good that I’m not the only one, but this isn’t a solution. It needs to be fixed properly. This is a bug in the basic functionality of Scrivener.

My post’s purpose was to provide additional information and to confirm your findings. Mr. Blount will likely insert the info into the hierarchy of his tasks.

Sorry. Didn’t mean to sound snippy. :wink: Just didn’t want the bug to get tossed aside. This one could be a real deal-breaker for me, and I just LOVE scrivener.

Hopefully this bug fix plus better support for large documents will come in future iterations. I’ve notice that when a document hits the 20k/30k mark, especially with images, things get a big laggy, even with an Air 2. Also, no real way to quickly scroll through so much text, something like how Pages uses a long-press on the right margin to pull up a page by page thumbnail, allowing you to swipe down and up through the entire document quickly. (I’ve got another post about this one.)

Scrivener is great, and the iOS version is almost there. I hope it matures to seamlessly function for the writer, ceasing to jar and stop the creative flow a little.

For the record, I think the lag is due to iOS more than anything Scrivener is doing. I suspect all apps when faced with such large documents get a big laggy. I imagine an iPad Pro probably doesn’t suffer from this, but I haven’t had the chance to try it out yet.

I’m curious about file size and lagging. When you say a size of 20-30K, what do you mean? Number of words in the document, or the actual size of the document on disk?

Currently I am working daily on a file that is now about 40K words and shows a size of 233K on disk on my Mac.

I use an iPad Pro 12.9 for Scrivener iOS and have never experienced any lag when searching, scrolling or whatever.

I don’t have any documents with that much content. It might be best to consume them in smaller bytes. You can combine them later on your Mac.

(No worries regarding the earlier conversation.:slight_smile:)

It might be because your 12.9 Pro has 4GB of memory. The Air 2 has 2GB. Maybe someone else will chime in that has an Air 2 or the 9.7 Pro.

I have an iPad Pro and use a bluetooth keyboard, and I encounter this problem all the time in Scrivener iOS.

In my testing, it only occurs if there is text after the word I am deleting. As in, if I’m deleting something in the middle of a document. If I am deleting from the end of the document with nothing but empty space after the cursor, deletion works fine.

However, if the cursor has text immediately after it (as in no space before the next word) then the bug does not occur. It only occurs if there is a space after the cursor, and then text after that.

I have never encountered it in any other program on iOS or on my Mac, and have used dozens of different writing apps. It appears to be a problem with Scrivener iOS specifically. Just to make it clear, I absolutely adore Scrivener iOS and the care being put into it. This bug is driving me absolutely batty, however. Especially considering that, a lot of the time, the system doesn’t recognize the combined words as being misspelled, therefore not underlining it in red, therefore making me miss it until I am proofreading the final document.

Thanks, I can see that behaviour as well, I’ve made note of it for Keith.

I’ve also moved this thread to the bug report forum.

Just saw that happening on iPhone6s (iOS 9.3.4), no external keyboard was attached at the moment.

Thanks, the behaviour occurs regardless of the keyboard as it’s to do with the selection deletion behaviour. We should have this fixed for the next iOS update, so that the preceding space is only deleted when the entire word is selected and deleted in one go.

I am experiences the same difficulties with the deletion of the space between words. I’m using an iPad Pro with blue tooth keyboard. I experience this difficulty in NO other app. It is a game changer and will force me to stop using Scrivener on the iPad. A very sad outcome.

The funny thing is that the bug was already fixed by the time it was reported. It was a secondary effect of the smart copy/paste code. And as noted, the problem should be gone in the next bug update.

Have you tried using Opt-delete to remove words instead of one letter at a time? I’ve never come across this myself, and I’m thinking that might be why.