deleted text lost through autosave

I’m completely new to scriv. what troubles me in the first few minutes of using it is the autosave, which writes over the original file rather than a backup in another location like word. if you accidently delete a paragraph or two then with two seconds it’s lost for good as the original file is overwritten with the loss included.

  1. Cmd-Z to undo. It even works between different documents. Made some mistakes in a document you just edited a bit ago? Open it up, press Cmd-Z and the changes will be reverted. Go back to the one you were working on before, and Cmd-Z will still work in that one too, independently. Does not work after you close Scrivener though.
  2. Take a look at the Snapshot feature, if you are used to the work model of having save points as milestones, that is what you are looking for.
  3. Rather than actually deleting text, why not just highlight it for deletion? Select a range, and press Cmd-Opt-A to turn it into an annotation (pressing it again while the text is selected will toggle it back off). Unless you tell it to, they won’t export or print when using the exporter, and if you are positive they really should go – you can snapshot them, and then wipe them all out at once with Copy without Annotations and Footnotes in the Edit menu, and then paste over the current document. Some people like to use strike-out, too. I like using annotations instead because it is so easy to delete them all when I’m done.

just to second the delete issue, I’m finding it too easy to lose something for good. What I’ve found is that if I’m going through documents in a file, on which I’ve written say some scene information, and I use the delete button to delete it, occasionally I’ve pressed delete twice and it deletes the next scene too. The curser automatically jumps to the next document. In effect it’s possible to delete everything by keeping your finger on one button, and very quickly too (as simple as deleting the successive letters in a sentence by pressing down on the delete key).

Of course, I shouldn’t have pressed delete again, but for some reason I did, and do do this, too often. I go looking for an Control Z feature to recover the loss, with no luck. Is there any way around this, rather than the obvious one of me not being so clumsy?

If you delete a file in the binder, it’s moved to the binder’s trash folder.

Dave

If you delete a file in the binder, it’s moved to the binder’s trash folder.

Dave

As mentioned, binder files get moved to the trash and can be restored.

Snaphots exist so that you never have to lose text through deletion. Before making major edits, hit cmd-5. You can then roll back to that earlier version at any time - even months later.

And as AmberV says, undo will easily let you restore deleted text - just hit cmd-Z. Each text document within a project contains its own undo stack whilst Scrivener is open, so even if you flick between documents, you can still go back to a document you made changes to, place the cursor inside it, and hit Undo.

But is sounds to me as though you have made some edits to a document that you then regretted - and this is exactly what Snapshots are for. The advantage of Snapshots is that if you have made some changes that you like but other changes that you don’t, then you have access to it all.

Best,
Keith

thanks.

thanks.

Thanks for the tips. Just spent a little time going through the tutorial - it’s a very cool writerly aid. Maybe this has been covered elsewhere but at my first attempt to import a current project split over several word files, the first lines or sentences in each file seem to come out as lots of space and random symbols.

Never heard of that happening… What language are they in? Scrivener uses the standard Cocoa methods for importing from Word, so I have no idea why this would happen.
Thanks,
Keith

I have seen some weird stuff happen with .doc imports in the past, though not with Scrivener – this was a long time ago. There might be some conditions in a Word file that trigger incompatibilities with Apple’s converter.

You might try exporting these files to RTF first, and then importing the RTFs into Scrivener.

Thanks AV I’ll try that.

KB they are in English, at first glance it appears that some of the problems are with punctuation. I could send you a screen shot of what it looks like.

Sending a screenshot sounds good. If you could send me a Word file that causes problems, that would be even better, though, as I can check to see if it is anything Scrivener is doing or a problem with the OS X .doc importer, and if there are any workarounds. The address to send to is support@literatureandlatte.com.
Thanks,
Keith

Saving as RTF before importing gets rid of random symbols and missing text but the edit view is not sizable, it’s stuck on the orginal word page width.

You mean that the Ruler (Cmd-R) does not make any changes to imported text when you fiddle with the margin markers? Remember to make sure the text of the document is selected when trying this. This is so the Ruler can set different tab stops through the document, amongst many other things.

Thanks Av. Do you know if there’s a short-cut to change imported text to the default font and style?

It’s an almost-shortcut.

Switch to a document that is in the default style. Click in a paragraph. Select Text Menu/Font/Copy Style. Switch to your imported text, Select Edit/Select All, then Text/Font/Paste Style.

Warning! This will not preserve style-mappings (bold italic etc.) Everything will be set to the default text face.

That should do it.

Dave

Select the document and use the menu Documents/Convert Formatting/to default Text Style. This also operates on a document – or entire edit scrivenings session – with the cursor in it (i.e that is being edited). And you’ll retain your italics etc.

Cheers,

E

As for the original Word document problem - Sigmund, I got your file, and it turns out the problem is as follows:

When Scrivener imports files, it looks at the extension of the file to decide how to import it. If it has no extension, it gets imported as plain text. In the case of this document, it has no extension, so Scrivener imports it as plain text, meaning that you see all of the internal gobbledegook of the .doc format. If you add the .doc extension, it imports fine.

As for the right margin, this happens with Word documents sometimes. As the others have pointed out, you will need to select all the text and change the ruler settings.

Thanks and all the best,
Keith

Thanks all.