Deleting Contents Page in ToC

I’ve compiled a mobi eBook using the Parts template. Each part has its own ToC: neat! But Scrivener automatically makes a Contents page for the ToC, which I want to delete or prevent it from appearing in the ToC. I’ve attached a screenshot below. The unwanted Contents page (which is blank: ie no contents) comes after Cover the second segment from the top.


I believe the Generate HTML table of contents setting in the Layout compile option pane should do the trick.

AmberV–You always come to the rescue, which is why I was worried when you weren’t around last month or so when I asked a bunch of qtns. Thank you. And thanks to all the Scriveners who did reply earlier.

I could kick myself for not trying your suggestion sooner. But I thought it would also delete the HTML connections in my Parts ToC, so I ignored the idea.

Thanks. :slight_smile: We’ve been busy getting the iOS version ready, and I haven’t had as much time to give to the forum of late. Thankfully that stretch is coming to a close!

Ah, there is an option that would do that, but it’s off in the Transformations pane, Remove all hyperlinks.

Hello guys!

I have the same issue on the Windows version. Do you guys have found the solution?
Thank you! :smiley: