Deleting word leaves 2 spaces

Unlike most modern word processors, when I highlight and delete or move a word in Scrivener, it leaves the fore and aft spaces, so I have two spaces between the remaining words and none where I moved it to. Is there a setting to change this behavior?

No, Scrivener doesn’t have the “smart copy/paste” feature at this time. It’s something we’ll look into with refinements to the text engine, but there just hasn’t been a chance for that yet.