Difference in response speed when typing text


When I type text on the keyboard, the monitor displays the text I have typed.

Comparing Scrivener and Mac Notes (or Simplenote, etc.), I feel that Scrivener’s display is slightly slower, can this be made faster by setting the app?

Scrivener is a much more complex application than Mac Notes.

Response time is largely a function of both the overall project size and the size of the specific document you’re writing in. It will also depend on your hardware: a small file on new hardware will be faster than a large file on old hardware. Anything that “watches” what you’re typing can also contribute: spellcheckers, grammar checkers, keystroke expanders, that sort of thing.

Are you seeing freezing or lag that comes and goes? Or do you just perceive routine typing as being a little slow?

Thank you for your kind reply.

Sometimes when I create many documents in Scrivener it slows down, but in this case I am talking about normal typing.

I asked if there is any way to type comfortably if the display speed is fast enough, so I was wondering if there is any way to do this when writing a long draft.

It seems to me that it would be better to use another application for writing drafts.

These can slow the editor:

  1. very large documents
  2. scrivenings mode (multiple documents displayed as one)
  3. embedded graphics (images dragged directly into Draft/Manuscript documents)

In case of #3, I recommend moving images outside the Draft/Manuscript and referring to them with $img tags. Here’s a workflow for that, slightly involved when setting it up, but very convenient afterward.

managing images in Scrivener

I write screenplay pages in Final Draft and then paste them into Scrivener for organization. Maybe you could type long draft documents in something like Sublime Text or nValt (both free) and then paste it into Scrivener?

How long?

Unless something else is “watching” your text, as explained in my previous post, Scrivener should be able to keep up with normal typing speed in a normal length document. If it can’t, something is wrong. Please open a support ticket, here, so that we can analyze your specific situation: