Different computers, same version, different problem opening

What am I doing wrong? I usually use Scrivener on an Intel iMac. Today, I installed scrivener on a PowerBook G4, and tried opening my main scriv file. Get a blank application window.

I tried creating a new scriv file. Same problem – blank application window.

In the existing scriv file, I can’t see any of my old entries, and in the new scriv file, I can’t create any entries.

What gives?

Is Scrivener not supported on the G4? Could it be that simple?

Scrivener is supported on a G4. Strange. Someone else reported a similar problem recently.

Some things to check:

  1. Which version are you using? (Go to Scrivener > About.) Is it the same on both computers? Were you asked to update the project at any point?

  2. Go to Scrivener > Preferences when you get the blank window, go to Fons & Preferences and check to see if any of the font pop-up buttons are blank. If so, pick a font for those pop-ups and then try re-launching.

  3. Open Console.app from Applications/Utilities and then launch Scrivener. When you get the blank window, look at console.app and see if anything gets written out there. Post whatever it says here.

Thanks!
Keith

Thanks, Keith.

#1: I don’t have access to my iMac at the moment - the computer with the version of Scrivener that works fine. However, I’ve only been using Scrivener about six weeks (I registered near the end of the evaluation period), and I don’t recall upgrading. The version on the PowerMac is one that I downloaded and installed yesterday. So I think we can assume that there’s no version incompatibility problem (although that’s the first thing I’ll check when I get back home Wednesday, assuming we haven’t been able to work out the problem before then).

#2 The font values are all filled in.

#3: And here’s the console log:

===== Sunday, September 16, 2007 9:46:55 PM US/Pacific =====
2007-09-16 21:47:05.344 Scrivener[380] *** Illegal NSTableView data source (<SCRSearchResultsController: 0x491c10>[object class: SCRBinderDocument, number of selected objects: 0]). Must implement numberOfRowsInTableView: and tableView:objectValueForTableColumn:row:
2007-09-16 21:47:05.647 Scrivener[380] Exception raised during posting of notification. Ignored. exception: *** -[NSPlaceholderDictionary initWithObjects:forKeys:count:]: attempt to insert nil value
2007-09-16 21:47:13.773 Scrivener[380] *** Illegal NSTableView data source (<SCRSearchResultsController: 0x5d725b0>[object class: SCRBinderDocument, number of selected objects: 0]). Must implement numberOfRowsInTableView: and tableView:objectValueForTableColumn:row:
2007-09-16 21:47:13.906 Scrivener[380] *** -[NSPlaceholderDictionary initWithObjects:forKeys:count:]: attempt to insert nil value

Thank you for your prompt response.

Eek. This is the same bug that someone else reported a couple of days ago. Bizarre, given that I have not encountered it before.

After investigating this with the other use who encountered this, it seemed to be the result of an interface file causing problems upon opening - but this would seem to be a problem with something specific to your (and the other user’s) system given that no one else has reported this. It would seem to indicate that something required by an interface file is missing on your computer. Some thoughts:

Have you ever played with the fonts on that system? With the system fonts? Is there anything on that system installed that might not play nicely with other programs?

I’m stabbing in the dark with this at the moment, I’m afraid, as it is very difficult to track the actual problem without being able to reproduce it myself (Scrivener runs fine on my iBook G4, for instance).

Best,
Keith