Different styles in editor and compile menu?

I think I have an understanding issue, and might need your help.

In compile > edit format; I have a lot of different styles. But what I do not understand, why those are not available in Editor Mode, and how they map to each other.

How do I assign text in my editor with those styles in compile settings menu?

Many Thanks :slight_smile:

You should see if there’s a Scrivomatic template project that has those styles defined in it. Create a “scrovmatic styles” project from that template, and then in your current project, import the styles from the scrivomatic styles project.

Hm ok. Where would I find this template?

It is not in the menu when creating a new project.

Another problem which I think is related to this:
Italic and Bold text styles are not applied to the markdown output, Despite the settings in the compile window, where the styles from scrivomatic are configured accordingly.

Where did you get the scriv-o-matic compile preset from? I just googled “scrivomatic”, and Iandol’s github site came up. I think a zipped sample project can be found there, named Workflow.scriv.zip. Unzip that, and then in your project use the Format->Style->Import Styles menu to get those styles into your current project. You might want to create your own template if you’re going to be using Scrivomatic compile presets, so you can start new projects with everything you need already set up.

Edit: The way compile styles are used is that any text in your project that are marked with a style of the same name will be transformed to match the compile styles. So you have to have your text in your project marked with the style “bold”, rather than just the un-styled, rich-text bold. Same for italics, or any of the other styles.

Yes, I found that. But how am I supposed to get the styles from one project to the other? This really isn’t as straight forward as I hoped for.

This worked, Thank you.
I just expected I had to export the styles first, but wasn’t able to find find an export option. :blush: