Disable Outliner Column Sorting

Hi all

Is there any way to disable outliner column sorting?

When you’re in outliner view and click on a column header it changes the order of the rows. Any way to turn this off?

Cheers

Don’t click on the column headers? :slight_smile: But seriously, the whole point of clicking on the headers is to sort the columns, so if you don’t want to sort the outliner, just don’t click them. If you mean that you just want to turn off the sort after having sorted them in the first place, then click again to reverse the sort and click once more to return to an unsorted view. Each click cycles through sort ascending, sort descending and unsorted.

All the best,
Keith

Ha! Thanks great tip :stuck_out_tongue: That’s the problem, while working at the top of the column, or moving columns around it’s easy to accidentally click on the column header and cause all the rows to jumble. I only ever want to view my rows in scene order (can’t imagine why you’d want any other order, personally!) so a setting to fix this order would be useful :slight_smile: