Disappearing Scrivener Project Files

When I use Compile to create a .mobi file and I navigate to the folder where the .scrivx file resides it has disappeared.

I can directly access the .scrivx file from its folder on my desk top. It will immediately open in Scrivener. But it disappears as soon as I attempt to Compile. I have ten individual .scrivx files I’m working on and this disappearing act is going on with each of them.

I’ve successfully used the Compile function in the past without problems. I don’t have the slightest clue as to what is happening. I would appreciate any assistance you can give.

Thanks in advance,

p.s. This also happens with any other book format (e.g., epub, etc.) I try to compile to.

Your antecedents are a bit ambiguous… are you saying that “When I use Compile to create a .mobi file and I navigate to the folder where the .scrivx file resides [the .mobi file] has disappeared”? or [the .scrivx file]?

First of all, you should never use the .scriv folder (where the .scrivx file resides) as an output location for compiled documents. The .scriv folder is the root of your project, from which all other internal files and folders “grow” from. So when you are compiling, make sure you pay attention to where it says it’s saving the .mobi file, and make sure it’s outside of your project.

On to your .scrivx file “disappearing”… Disappearing from where? Obviously not from the Windows file browser. You state that you can always find it. So, I’m guessing you mean from the File->Recent menu in Scrivener? Does the Recents menu usually show anything if you don’t compile?

Thank you so much for responding. I apologize for the ambiguity in my post.

My problem precludes me from compiling a .mobi file in the first place. Therefore, to answer your question, it’s the .scrivx file that seems to have disappeared. I say “seems” because I can directly access the .scrivx file from its folder on my Desktop. The file exists…it’s there. It will open in Scrivener.

It’s only when I try to use the Compile function to create the .mobi file, and I navigate to that same folder that the .scrivx file is no longer to be found. (BTW…I have always saved my .mobi files in a separate folder - not with the .scrivx files.)

Please see attached screen shots:

Screenshot1 shows the file (SOT Book Two.scrivx) in its folder which sits on my Desktop.

Screenshot 2 shows no such file (SOT Book Two.scrivx) after I’ve navigated to same folder, following the Compile steps in Scrivener. The correct path is displayed in the Window Dialogue Box.

Screenshot 3 shows the Recents menu from Scrivener

I hope I’ve provided the information that answered your questions. As before, I appreciate any assistance you can provide with this matter.

Why are you navigating inside your project when you are compiling? :open_mouth:

Your structure is strange. It looks as if you have saved projects within projects…

Put bluntly, your file structure is a mess. You appear to have nested multiple Scrivener projects inside each other. Difficulty compiling is the least of your worries: ALL of your data is very much at risk in this situation.

A normal project contains, inside the top level .scriv folder, the following items:

  • The Project.scrivx file.
  • A Files folder.
  • A Settings folder.
  • A Snapshots folder.
  • Possibly a QuickLook folder, if it’s been shared with a Mac OS system.
  • Possibly a Mobile folder, for iOS synchronization,
    and NOTHING else.

Your Screenshot #1 has all of that, but it also has two anomalous .scrivx folders – itself a danger sign, as the master .scrivx document is a file, not a folder – and NINE .scriv folders.

This is a problem.

The second problem is that you are trying to save your .mobi file inside the project structure, which, as rdale pointed out, is a terrible idea. NOTHING should go in the .scriv folder except the internal contents of the project.

So, what to do about it?

First, backup everything using whatever third party backup tool you prefer.

Second, create a brand new folder somewhere like your desktop. Call it something like Recovered Projects. Create another one called something like Output Files.

Then, from the Scrivener Recent Projects menu, open your projects one at a time, confirm their contents, and use the Save As command to save a copy of each to the Recovered Projects folder. Close each project before opening the next. Use unique names so you can tell them apart. When you are done, the Recovered Projects folder should contain folders named “NewSOT Book Two.scriv,” “NewSOT Book Three.scriv,” and so on.

With Scrivener closed, browse to the Recovered Projects folder, open the NewSOT Book Two.scriv folder, and confirm that it contains a correctly formed project as described above. If it does, double-click on the .scrivx file to open it.

Now, Compile to .mobi format. Put the output document in the Output Files folder you created up above. Does that work correctly?


Hi olirom,

If I were you, I would follow Katherine’s advice.

To answer your original question, the reason you’re not seeing the .scrivx file in Screen shot #2 is because “Save as type” acts as a filter, and is currently set to only show you .mobi files. Which makes sense, because Scrivener compile is trying to create a .mobi file.


Thanks to everyone, especially Katherine.

My lack of tech savvy is definitely on display here. :unamused: I’m so grateful you all are here to help.

So, per Katherine’s suggestions, I’m currently backing up my files. I’ve also created the Recovered Projects folder, as well as, the Output Files folder.

Any tips, going forward, for avoiding another hot mess?


Never, ever, ever save ANYTHING inside a .scriv folder. Not a Scrivener project, not an output document, NOTHING.

Make sure extensions are displayed in Windows Explorer so that you can tell which ones the “,scriv” folders are.