Disappearing Text

Hi guys,

Every time I cut and paste some text from one of my reference notecards into the main document text area, then close the file and reopen it, portions of my text disappears. I have since 1) moved the file from DropBox and saved to my documents folder on my hard drive, 2) Saved As a different file name, 3) tried retyping portions of the text and it still happens (albeit different portions of the text), and 4) tried opening the manual backup file to see if changes were successfully made there- None worked.

I am very nervous about continuing to use Scrivener despite liking its interface. If I keep losing data, regardless of my back up strategies, then I cannot use this. Can you offer a suggestion?


Somebody from Tech Support will have to troubleshoot this, but I thought I would just say as another user that I have been using Scrivener off and on since about 2007 and I don’t think I’ve lost so much as a comma. I certainly wouldn’t be nervous about it myself – I’ve rarely used anything so reliable.


The handle!!! Priceless!

I can’t wait till vic-k figures that one out.

I don’t have an answer, but two questions come to mind which might bear on it.

1/ Is there a pattern to the loss – the amount, the location in the text, the kind of text?
2/ Does the same thing happen with Copy > Paste?


Yes, I copied and pasted from an index card header in my references folder. Interestingly, the first half of it stays but the last half or so disappears… And, the amount of text varies with each close/reopen… Obviously it must be corrupted, but I would prefer that it show me instead of saving, backing up, and then still losing the info… I also found that it lost data when I copied and pasted into Pages from the Scrivener text. Again, it looks just fine in Scrivener, but deletes large portions when I copy and paste into Pages… Go figure.

Odd. Is the space where the text “should be” a chunk of whitespace just missing the writing?

Again, it is interesting that the text disappears usually before a number like “blah, blah blah 5th Element…“ It will only be saved as “th Element…“ The entire three paragraphs before it, just disappear. Big white space.
I can only assume that things I added to the Note card header were corrupted. Because I copied and pasted them right into the main body of the same Scrivener document and they just will not stay following closing and reopening the application…

Very unlikely, but if you do a command-a then change the text font, does the text show back up?

It “sounds like” something might be setting the text color to white. This would transfer to pages hence the matching behavior.

No, just disappeared. Not enough space for the text to be there… I was missing two to three paragraphs (not even all that was cut and pasted) and there were only a couple of lines in the gap where the text was missing. Same in Pages. Again, I will chalk it up to corrupted text, but it sure would be nice if I could know that beforehand. Even after doing a manual back up, the text in the back up was gone… Even though it looked and acted just fine prior to closing the file…

I’m going to move this to the Bug Hunt forum. It sounds similar to a bug that another user encountered recently whereby editing one synopsis could result in another being overwritten. That bug – if it’s the same one – will be fixed in the next release. (Keith: I’m referring to the bug where the card ended editing before the view was swapped out.)

A few questions:

  • Can you make this happen consistently? And if so, can you provide a sample project and/or a list of step-by-step instructions to reproduce it? (I wasn’t able to reproduce it on my system.)

  • Are you viewing the card data in the Inspector, or in a Corkboard view?

  • Are you closing the project immediately after the copy/paste, or are you doing further work and then closing it? Or doesn’t it matter?

  • You said the error happens if you copy from one of your reference notecards into the document text. Are you copying from the notecard to the document associated with it, or to a different document? Does it also happen if you copy from a notecard in the Draft folder?

In the meantime, have you tried the command Documents -> Append Synopsis to Main Text as a workaround? That might not be as neat as a copy and paste, especially if you want to put the index card data into a different document, but might get the card data into an editor window without irritating the bug, and from there you can move the text wherever you like.

Hope this helps,


People, none of you seem to have noticed that the OP says “Index card header”, and you’re talking about the synopsis area in the body of the card. Is the problem not that the OP is trying to type all his text into the header-line rather than the body … and that each time he adds more text at the end, text at the beginning has to drop off as the number of characters is limited.

Should the OP not be typing all this data into the synopsis area before trying to transfer it?