Disappearing work

I’m having serious issues with Scrivener. Looks like it has to do with the latest update, this has never happened before and I’ve been using Scrivener for quite a while now.

I was having no problems at all until I opened my current project yesterday. I could see all the titles of the files, but to my horror everything else was gone, just one blank page after another. I just uninstalled and then installed Scrivener again, then manually pasted every scene to its place from my backup file. I closed the program and opened it again - and the pages are blank again. I’m really frustrated, and needless to say I won’t use the program again until I know if I’m doing something wrong.

If anyone has any idea what is going on, I’m really grateful.

If you are using a cloud service to backup or sync files, @robertdguthrie has some useful tips in this thread…


I’m so sorry you’re experiencing such a problem! Have you checked in the Files\Docs folder of the project’s .scriv folder to see if the files are listed there but incorrectly named (e.g. with “conflicted” or such appended to the name)? That would be one possible error with a Dropbox sync which would prevent the documents loading correctly in Scrivener. If the files aren’t there at all, you could try checking on the Dropbox website for “previous versions” or “deleted files” to see what kind of record of their history you can find, which might give a clue as to what happened and when they went missing. (If you’re on Vista or later, you can also try using Windows’ “previous versions” of files to restore missing documents, though it sounds like that may not be necessary since you had a backup.)

Another possible cause would be if the file path to the project changed while the project was open in Scrivener, though it seems unlikely since you had this occur so quickly the second time. Still, you may want to try using the Windows search tool to look for either another copy of your project by name or some of the text of the missing files to see if you can find a second copy of the whole .scriv folder on your machine. If you do, then probably you’ve got a couple incomplete copies that could be restored into one, and the solution then is to figure out what caused the file path to change (resulting in a split save, basically, where Scrivener was still auto-saving to the original location since it didn’t know the project had moved).

I’ll also direct you over to this thread; although the initial issue reported is somewhat different from yours in that it was new edits not saving in certain circumstances, when walking through the possible issues, Tiho gave some directions for checking the permissions for saving and so on that could still be relevant to you. In that case the problem turned out to be a backup service that was constantly running on the drive and was conflicting with Scrivener, so that’s something else you might want to look out for here, but also it could be worthwhile to work through Tiho’s various instructions if none of the above ideas fit the case, since they may help determine the cause of the problem.

Thank you for your advice, Jennifer. I wasn’t able to locate the missing files with the search tool. I did have backup copies of my work however, most of it anyway. My biggest concern is that something like this will happen again when I won’t be prepared. :blush: I just need to be extra careful with backups and save often.

I still haven’t figured out what I did to cause the whole thing, that will remain a mystery I guess. As far as I can see I did exactly what I normally do. I’ve been using Scrivener (along with Dropbox) since July 2012, and have had no problems at all. I’ve pretty much grown dependent on Scrivener, so I’m not giving up this easily. The program is working fine for now, let’s hope it will stay that way!

I’m sorry the search didn’t turn anything up. Do you have any software monitoring the folder or drive where your project is stored, a backup or security service for instance? As I mentioned above, another user had an issue with changes in the 1.5.6 update due to Acronis running constantly for that drive; he resolved the issue by moving the project to a different hard drive not monitored by Acronis (and some further changes went into 1.5.7 that we’re hoping should prevent the issue). A while back someone had a similar experience with Carbonite fouling up files when making a backup. If you have another drive or partition handy, it may be worth moving the project to that (when it’s not open in Scrivener) and working from there for a bit to see if it clears up the issue–though if you’ve only seen this happen the one time, it’s probably not going to be easy to tell if that fixes anything or not. Definitely check though whether there’s any other software monitoring the drive where the project is sitting, as some kind of conflict here is a high probability, and we’d like to figure it out and make sure it’s fixed.

In the interest of bug zapping, could you also let us know the file sizes of the individual documents you’re working with in the project that saw the problem? If you drill into the project’s .scriv folder, these will be in Files\Docs; you can switch to the Details view in Windows Explorer to see the file size for the various rich text documents that make up the project. Then could you right-click on the drive name and view Properties to check the amount of free space and right-click the computer name in Windows Explorer and choose Properties to check the amount of available RAM. (You can also access the system information via the shortcut Windows Logo Key + Break/Pause.) Scrivener writes some temporary files when documents are being edited, so it’s possible something went afoul here if you were running low on memory.

I have had the same problem but used this advice to find the lost files in a Word Rich text format. Thank goodness I hadn’t lost it all.

My question is, what should I do now? Should I paste the Word text into my existing project or start a new project with a different name and paste it into this?

A second question is, what caused this and how can I avoid it?

I have just opened my Scriv project after a few days of not working on it, also to find that none of the pdfs in my Research folder are reading. They just show blank! :cry:

As this is the project for an academic paper to be presented overseas in 3 weeks time I am quite concerned. All the texts are OK, just the pdfs are blank.

I am wondering if this dates to the recent version update

Please advise what I should do to recover the content of these pdfs.

Martin - When you say you found the files, where were they and how were they named? A project’s files are stored inside the project’s .scriv folder (ProjectFolderName.scriv\Files\Docs), so I’m wondering here if you found them within that folder and for some reason they aren’t loading correctly, or if they were elsewhere on your computer–perhaps saved in a different copy of the project or such. If they do appear to be inside a project’s folder, if you open the project by moving up the directory tree in Windows Explorer from where the RTF files are until you get to the project (.scrivx) file and double-clicking that, are the documents still blank in the project? Do you get any error messages? Or are these documents appearing but other files blank? Knowing where the files are in comparison to where your project folder is will help determine the best forward action. Ideally we can just move the RTF files back into the correct directory and that’s that; alternatively, it might end up easiest to re-import these items back into the project binder or to just restore from a project backup.

While checking that, try also going into Scrivener’s options (Tools > Options) and in the general tab, select “Show full project path in the title bar”. Especially if it turns out you have multiple copies of a project with the same name, this can be extremely helpful in figuring out which project you’re looking at in Scrivener compared to where files are on the computer.

At this point I can’t say what caused the problem, but once we’ve sorted out where the files are and so on it might become clearer. It could have been a problem with saving if the project folder was moved while it was open in Scrivener (“moving” means any changes to the file path, so for instance renaming a parent folder would constitute a move) or a synchronisation issue if you’re using Google Drive or similar to store the project; it could just be a an RTF reader problem if the files are in the project but not loading.

dahurn - Have you tried selecting one of the PDFs and using Documents > Open > Open in External Editor to see if the PDF will load in an external editor? Since this is limited to the PDFs, my first guess is that it’s a problem with the PDF reader not displaying them, and not necessarily anything wrong or missing with the files themselves. If that doesn’t work, try going to the Backup tab of Tools > Options and using the button there to open the folder of automatic backups, then copy out the last couple backups for this project prior to when you opened it today and the PDFs didn’t load. Paste these somewhere convenient for temporary access (the Desktop is fine), then starting with the most recent, unzip it (right-click and choose “Extract All” or double-click to open it and drag out the folder inside) and open the project in Scrivener to see if the PDFs load correctly. If the backup is fine and contains all your latest work, you could just replace the corrupt version with that. In that case, before deleting the project that isn’t working, open its .scriv folder and drill down to Files\Docs–do you see any PDF files listed there? If yes, are you able to select and open them in Adobe Acrobat or other PDF reader?

I started a recipe book and now can’t find it. It’s not listed under projects. Any ideas?

HeidiHO - Have you tried searching for the project name in the Windows search? The “Recent Projects” list just gives the five most recently accessed projects, so it’s not going to be a complete list of of all your work. If you’ve moved or renamed the project outside of Scrivener, that could also cause it to be removed from that list, since it’s just a bunch of shortcuts and changing the file path to the project would mean Scrivener could no longer find it automatically from the old link.

Jennifer (MM), thanks for your detailed suggestions! Sorry I have not been on here since. I forgot to subscribe to the thread. I actually uninstalled Scriv, and downloaded it again, and was tremendously relieved to see the pdfs could be read. I don’t know what that was about… maybe something was lost in the translation when the last two updates came through.

I am not very tech savvy with the inner workings of Scrivener yet – how to access and use backups within the project is still a mystery. I back up manually each time through File>Backup to a thumbdrive. And getting round in the files themselves is alarming… I am afraid I will corrupt something. I will get there, but it has all been a steep learning curve. It is miracle enough that I am using Scrivener pretty well!

I am thankful for this forum for when I need it. Unfortunately when I do it is a crisis situation :frowning: If I had more time to just read and absorb the general advice I would no doubt do better.

Hi all,
apologies for the delay in getting back to you.

You had some technical questions, Jennifer. As for the file sizes I really couldn’t say, since those were the files that got deleted… The amount of free space on my computer then: 866 Gt (I’m using 47,3 Gt of 914 Gt). Available RAM: 4,00 Gt. Does that make sense? Following technical advice is somewhat tricky for me - I’m not very tech savvy either, plus English is not my native language. :unamused: