.doc & docx compliles do not import into the new Kindle Create app

When I complile my novels to the Word formats required by the new Kindle Create app I recieve an error that an issue(s) can’t be resloleved by the program. I have tried removing images so that it would just be text but nothing seems to help. I have tried compling several versions in .doc and .docx formats and still no luck. Any advise? I am using v3.1 on a Mac.

Have you contacted the maker of the software that cannot open the files? I’d say that would be a better place to start an investigation than the thing making the files you are trying to import, seeing as how they can more fully test what is going on inside the software when it tries to open the file. I can only tell you that our .docx files are created by the Aspose converter, and in most programs they work fine.

But if I were to guess, what most often happens in cases like this is that companies will create their .doc/x importer to very specifically only handle content created by Word. Files created by unofficial .doc/x generators may not match whatever assumptions they made, even if the file itself is perfectly fine and technically valid. Thus it is often a better choice to compile to RTF from Scrivener, which is a native format for both Word and Scrivener, and have Word handle the creation of its own file format.