Document->Convert->Default Formatting - Bug?

There are 2 issues here First - how the “Use Formatting in Current Editor Works.”
Second is the behavior of Documents->Convert->Default Formatting

I’ve set the default formatting in File->Options->[editing]->[formatting] using a few methods.

I’m after a line spacing of 1.1 and an after paragraph spacing of 5pts. Which reads 1.1x 0.0/5.5 in the format bar. The font is Palantino Linotype |Regular | 11 | Center justified. Right Indent is set to 5.5, which I find is a good width for editing. I had been using a right-indent of 4.5, but that was feeling a bit cramped. Which led to the bug with Documents->convert.

I still need to test the output to Vellum. It seems to work fine on the Mac version for Vellum output to Mobi/ebook and print for (from memory) a 5.5"x8" hard copy, which I published on amazon.

Using the button “Use Formatting in Current Editor” has the following behavior.

The font is correct - the line spacing is correct - the paragraph spacing remains at 8.3 (not sure where that came from as I’ve never entered anything like an 8.3 or 5.3 or anything with fractional points. I lose the Right Margin setting. While it shows center justification - the test lines (unchangeable) are not long enough to validate this. I’m not sure if this is working as intended - if so, it’s a bit confusing.

Workaround - manually set the paragraph spacing by selecting the paragraph spacing option list select and choosing ->Other. Set the Paragraph spacing.
Right-click on the ruler bar and set Right Indent.

============
Setting the Project formatting
Normally I don’t bother with this, but in an attempt to fix was seems to be a bug in the Documents->Convert->Default Formatting, I’ve tried the following:

  1. Ignore this (The font, line-spacing, and paragraph spacing were not what I want - but everything is grayed out), leaving the “Use different formatting for new documents in this project” - UNCHECKED.

  2. Checking the “Use different formatting for new documents in this project” and manually matching it to the settings described above in File->Options

  3. Setting it and then unchecking the box.

All result in the following behavior when using Document->Convert->Default Formatting
A pop up appears - no boxes are checked. I continue with no boxes checked as I want it to adjust font, paragraph spacing, line spacing, and right indent.

What happens is the font, paragraph spacing & line spacing are correct, but the right indent sets to 3.31 (maybe 3.3), and Line/Paragraph Spacing is set to 1.1x 0.0/3.0

Nothing I’ve tried seems to affect this.
At this point, I’ve decided to set my paragraph spacing to match at 1.1x 0.0/3.0, which is fine, and I’ll just have to adjust the Right Indent manually.