Document > Convert > Text to Default Formatting...

… doesn’t seem to work right. Either that or I don’ t understand the intent of the command.

In the main Options dialog box, Editiing tab, Formatting panel, the “Main text style for new documents” is set to:

  • Ubuntu, Regular, 13
  • 1.2x 15.0/15.0

When I use the Convert command to change text of a document to default formatting, I get this formatting:

  • Ubuntu, Regular, 13
  • 1.2x 11.3/11.3

No idea where the 11.3’s are coming from.

Thomas

Scrivener has two places to store your default format – globally where you found it, and on a per-project basis under the Project Settings. Do you have a slightly different format with the 11.3s defined there?

The option to “Use formatting in current editor” (in the same panel of the Options dialog box) also produces eccentric results WRT to paragraph spacing. The current editor was set to “1.2x 15.0/15.0” as noted.

When I applied the command, the default got set to “1.2x 20.0/20.0”.

Thomas

Thanks for the fast reply.

No. In the Project Settings box, the option to “Use current formatting for new documents” is unchecked.

RC11, if that helps.

Thomas

We might have a slight mis-communication. The “Use Formatting in Current Editor” button in Options/Editing/Formatting and the “Use Current” button in Project Settings/Formatting are not checkboxes. They are buttons that, when you click them, take formatting from your currently selected text and set that as the new default format used when you create new folder and files from that point on. It won’t update anything you have in place currently.

To affect existing text and change it to comply with your default format, you can use Documents/Convert/Text to Default Formatting.

Yes, mis-communication, Devin. Two very similar names, but different. And my fault for not being more clear.

I’m talking about “Use current formatting for new documents”, in the Project Settings box. You’re describing "Use Formatting in Current Editor"in the main Settings box. Not the same idea, even though the language is incidentally quite similar.

Thanks for the reply. My fault for not making it clear what I was looking at.

Thomas

So they actually are all related!

Options/Editing/Formatting describes the Scrivener-wide, cross-project default text format that will be used for all new documents in all projects (with one caveat). The “Use Formatting in Current Editor” is a shortcut for setting this main text style – you select text in the editor that is formatted how you like it, go into these options, click this button, and the settings in this window update to match the selected text.

The caveat I mentioned above is that each project can override this global default and have a per-project default: Project Settings/Formatting. If “Use different formatting for new document in this project” is checked then the project’s specific main text formatting options are used for new documents, and clicking “Use Current” here sets the project-specific default text format the same way that “Use Formatting in Current Editor” sets the global default text format options.

A couple of us have previously noted that there seem to be some inconsistencies about paragraph and line spacing being picked up by “Use Formatting in Current Editor” for the global options and “Use Current” in the per-project options. However, IIRC, the issue with the global options was found to go away if you manually selected the paragraph with your cursor before going into the options and clicking “Use Formatting in Current Editor.”

Just to recap, you have your global options set to the desired font, size, and 15.0 spacing, and using the Document./Convert/Text to Default Formatting is not resetting the line/paragraph spacing correctly for an existing document? If so, when you create a new test document, is the formatting correct?

Correct, Devin, unless I misread the paragraph above in haste. The following, from my original post, describes the problem accurately. (I checked it again this morning.)

In this case, when I wrote “[manually]” above, I mean I edited the settings in the panel itself. I did not use the cursor-in-paragraph method to pick up settings from a document.

Thomas

More on Default Formatting. It now seems that the display in the Options > Editing > Formatting box — meaning the example, changes appropriately when Use Formatting in Current Editor is clicked. That is, if the setup in the example doesn’t match the current editor, it changes.

What’s messed up is the reading in the paragraph toggle above it. WRT spacing before and after, it just doesn’t match the presented setting in the similar toggle in the Editor.

If I change the paragraph spacing in the Editor, then go to Options and click Use Formatting in Current Editor, the numbers for paragraph spacing don’t match the Editor’s numbers. Interestingly, the line spacing numbers do change appropriately.

So, it’s not that nothing changes; it’s just that the after-change read-out is wrong. (Either that, or the Editor’s readout is wrong, but I tend to doubt that.)

HTH,

Thomas

I’m having this same issue. For some reason now there is a sort of multiplication going on between the editor and the settings.

When configuring Options → Editing → Formatting with the desired paragraph spacing, using Text to Default Formatting will set the actual text in the editor to be a fraction (my setting of 8 pt will become 4.8 pt).

When setting the editor to the correct spacing however, it will multiply the value when clicking Use Formatting in Current Editor (8 pt becomes 13.35 pt).

But creating a new document will use the correct paragraph spacing, which means a workaround of setting the global formatting to 13.35 pt isn’t helpful either.