Document title as a section header

Hello,

After some reading on Scrivener 3’s new compile system, I’m having a hard time wrapping my head around the theory of it and something that I feel like should be very simple is giving me some pain.

I’ve been working on a journal, and I have it set up so that each day is a document, in a folder by month, in the manuscript of the year. I’ve been titling the documents “29th, Monday” and so on, and would like to use this as a section title on export. However, when the export runs by default the end of one document goes into the next with only empty space. I’ve fiddled with all I can think of and I know this is probably an easy fix, but how do you set up the export to put “29th, Monday” over the section and then the body of that document below, and 30th, Tuesday below that and so on?

As to the question on how to get a title showing for each entry: that is what the middle column in the compile overview screen is for. Click the Assign Section Layouts… button at the bottom, and for the type of document that you use for journal entries, scroll through the available choices and pick something that works roughly like what you’re going for. Click on the tile and then click OK to set up the assignment. Depending on the Format you are using you might find something that does everything you want. For example the Titled Section layout that many of our defaults provide, will ensure a page break, a formatted title based on the binder item’s name, and then the body content to follow.

But if you want to create your own, or would rather start with a different Layout that doesn’t have a page break by default, this is something that can be easily changed in the format designer:

  1. Open up compile, and in the middle column hover the mouse over the preview tile you’re using for journal entries. You should after a moment see the name of the Section Layout that is being used for it.
  2. Right-click on the Format in the left sidebar and edit it (duplicating if necessary).
  3. Go into the Separators compile format pane. You have two choices here:

[list=1][*] You can safely assume you want a break above all sections no matter what. In that case, click on the the Text Files section in the Default Separators section at the top and set both before and between options to Page Break. Next, go to the Layout that you referenced in step 1 and ensure it is set to use defaults at the top of the options pane.

  1. The other approach is to simply make sure that items using the journal entry layout always get a page break, and leave the defaults alone. Click on its entry in the Separators sidebar, disable the Use default separators option, and set the before and between separators to Page Break.
    [/:m]
    [
    ] You could use the Test… button at this point to test your settings. If it all looks good, click OK and compile or save your settings (hold down Option and click the Save button to save your compile settings without compiling).[/*:m][/list:o]

And of course if you want to adjust the appearance of the layout you’re using, the Section Layouts compile format pane is where you would do that. If you used Scrivener 2 in the past, you’ll probably recognise much of how this pane works from the old Formatting compile pane.