Document Title in Scrivenings

Under what circumstances does a Document Title appear in the document itself? I would like it to appear all the time. How can I enforce this?

(actually, you’d want to uncheck “for Folders”, but in general…)

1 Like

Just realized – Titles appear in Scrivenings, but once you are inside the document itself, it doesn’t apply. Now I understand the behavior, although I’d still like to change it.

There’s another case: Documents that don’t have a title. They too won’t show one in Scrivenings mode (surprise).

Other than that… there’s the document title in the navigation bar above the editor. Or you could just stay in Scrivenings mode and edit your document there.

Maybe there’re more options that I’m not aware of, but I suspect this could be a feature wish.

1 Like

You can’t show titles in the document itself, but you can show them in scrivenings. What’s the use-case where that’s not enough? What are you trying to accomplish?

Are you speaking about a compiled document?

Not sure how I did it, but when I compile, all my chapter titles appear in the document while none of the nested document titles appear. I think I had to change a setting in compile to make that happen, and I think it has to do with folders versus files.

But that’s a really helpful feature, because this allows me to have multiple documents in the Binder, Editor, Corkboard, and Outliner, yet those titles and divisions are invisible once compiled. Documents appear as single chunk of text, just like they would in any book. The only one that can see multiple documents and their titles is me.

It does not.

There are a couple ways to have Compile add titles to a section layout. Here’s one, using <$title> in the prefix or suffix (suffix in this case). I prefer this method, because I use those panes for other purposes as well.

Or you can click the Title checkbox: