Document view bugs

Hi,

My project is about 100 000 words.

Opening the whole project in Document View induces a whole bunch of bugs:

  1. Many text chunks are not included in Document View
  2. Some of text chunks are included in such a way http://bit.ly/1qqIGSN
  3. Trying to find “Next” some text with F3 shortcut while being in “Find” menu produces “Bad allocation” error

Not to mention Scrivener crashes periodically when trying to switch mode to Document view.

What can it be and how to fix it?

Thanks.

Hi again,

Is there something wrong with the question? I have no reply for three days.

Thanks.

Possibly related to this?
https://forum.literatureandlatte.com/t/scrivenings-per-document-word-limit/27285/1

:question:

Thanks, SarsenLintel, I suppose it is related, but I would like to get more concrete answer form someone form Scrivener - is that a bug, would the bug fixed, when it will be fixed, etc.

Thanks.

Sorry for missing this one earlier. Scrivenings is a bit sticky at the moment, and we’re in the process of completely overhauling it for the next major release. Viewing a lot of lengthy documents together causes some display glitches like you’re seeing, where text doesn’t appear at the proper size or isn’t visible, either with a blank white space there or with the divider appearing as though it’s the end of the document. The best way around these bugs is to work in smaller chunks, and make sure you set the zoom for the editor before you enter Scrivenings mode. So e.g. rather than loading your entire manuscript, just select the first few scenes with a Shift-click in the binder. I realise it’s not ideal, but it should help sidestep these bugs until we can get it fixed.

I have not seen the bad allocation error in this situation before, but someone else did recently report getting it and/or a crash/hang when trying to load a large search collection in a big project that included a lot of images. Bad allocation is a memory error and I’ve only seen it crop up in Scrivener in relation to large images, either inserted into a text or imported (particularly when loading multiple). Does your project include any images? Are you only getting the error when you’re using find on a large Scrivenings session of your entire draft, or is it popping up in other scenarios also? Do you have many other programs running at the time?

When you say that Scrivener crashes switching to Document view, do you mean to Scrivenings, i.e. loading multiple documents in the editor? Folders usually default to a group view mode, but they can also be viewed in single document mode, displaying only their own text, and I’d like to clarify if the crash is happening when going into that single doc mode or only when you’ve got a big session loading (or failing to load, as it appears). Thanks!

That`s ok.

I have figured this workaround out by myself already. It is not very convenient in case you work with a word through the whole project, but it is better than nothing.

Nope, there are not any images.

As I can remember it pops up just using find on a large Scrivenings session of the entire draft.

Some of them, sure enough, but I have at about 20% free memory and plenty of CPU capacity during the search.

Exactly.

The crash is happening when going into the single doc mode.

Thanks.

For the word search, you may be able to trim the length of your Scrivenings session by using the project search first to get a list of just the documents containing the search term, then loading those into the Scrivenings session to skip through each instance with the regular find tool. If it’s a common word that may not help much, of course.

About how large is your project (file size) and how many documents are in the Draft? What’s the approximate word count for the full Draft? (I’m assuming here that this is what you’re loading into Scrivenings that’s frequently getting the error.)

When you get the crash going to single document mode, is it when you’re switching the view on a container–e.g. you selected a folder and it’s displaying on the corkboard, and you deselect corkboard to show just the container’s text? Or is it when you switch by loading a single document (which defaults to the text view)? Have you noticed it occurs only for a particular document or when switching from a specific view mode?

Good idea! Works with non-frequent words, thanks. But if I had known earlier :frowning: - I followed-up already with more elaborate way.

As I said in the first post - 100.000 words, about 500 text chunks.

The bug appears just if I switch to Scrivenings mode from the whole draft no matter what view I switch from (default, corkboard, whatever).

I have tried the workaround - it does not work for me. First, F3 (Find Next) works just within one text chunk, so to “find next” in another chunk in Scrivenings mode you need to move the cursor to another Scrivening (text chunk) with the mouse. Second - it is almost impossible to select two or more words in the text, that has been found this way in Scrivenings mode. I suppose you`d better fix the issues I mentioned in the initial post.

Find Next should work across Scrivenings sections, so I’d need more details to know what might be preventing it in your case. If I select multiple documents, as from a search collection, load them in Scrivenings, then use Ctrl+F to open the Find dialog and enter the search term and use either the Find Next button or F3 to go to each instance, it takes me right through the entire session.

Do you mean you’re using project search for an “any words” or “all words” search, so you want to find instances of any of multiple listed words? That isn’t possible with the regular in-document Find, so you’d need to look for each word individually.

Not in my case - I do the same - I got stuck in the first text chunk.

I mean - it is almost impossible to select two or more words in the term, founded with “Found next”, e.g. I insert “New search term” in the Find box, hit “Next”, get redirected to the term next entry, and trying to select the whole term (all three words “Next” + “search”+ “term” together) with the mouse - almost every time it does not work.

Could you perhaps create a quick screencast showing what’s happening, starting from creating the Scrivenings session? That sounds like a bug, but I can’t recreate it.

Same for the multi-word search. If I have “this same phrase” multiple times throughout the various documents, and I use the regular Find/Replace to search for “this same phrase”, then Find Next will select the entire phrase in the editor for each instance of the phrase. You shouldn’t need to use the mouse at all, unless you’re trying to extend the selection or select only a smaller portion of that search term phrase, in which case it clicking into the editor outside of the already selected text should clear the selection, allowing you to select whatever text you want as normal.

I wonder if you have Typewriter Scrolling enabled? That keeps the current line of text centred vertically when you’re typing, but in Scrivenings mode it can make selecting text a challenge because it scrolls incorrectly (related to the bug described earlier, so also will be fixed with the reworking of Scrivenings mode). With focus in the editor, check Format > Options > Typewriter Scrolling and toggle it off if it’s currently enabled. That might address the trouble you’re having with the text selection.

Screencast is here goo.gl/N2FZcL

Sure enough, it`s exactly I have tried to do.

That was exactly the case - after unticking Typewriter Scrolling everything goes smoothly. An old bug is better two new ones :smiley:

Thanks

Thanks for the screencast. The trouble is that you have it set to search in “selected text”. Switch that to “entire document” and you should be set.

Right you are, thanks!