DOCX converter passes illegal Gremlins

I was seeing this error when using Scriv’s in-house DOCX converter.

conversion error.jpg

This error only showed up when Enhanced converters is turned off, i.e. when Scriv’s in-house converter is in operation.

Zapping gremlins solved the error, and I have reason to believe that the offender was a NULL character – what in the Before Time would be described as a character with ASCII code zero.

So, this is just to say that the enhanced converters handled such illegals gracefully, while the Scriv converter appears to have just passed them on into the XML – with the result that Word choked on it.


Did your text have an image in it, and was there a space character in the image name? When Keith first launched this, I got exactly the same alert, and that turned out to be the reason.



No, no images in this case, though. Like I say, I have reason to believe there was a NUL character in there. My mindmapping software has a persistent bug: if one uses a particular key command, it introduces a NUL character into the text of the selected node – very annoying. Spotted the little devil when it was rendered visible when opened in another app. Also, Zap Gremlins cleared the prob in Scriv, which would not have worked, if it was a space.

Could you please post a sample project so that I can test this for myself?

I successfully reproduced the problem with the attached test project.

DOCX Converter Passes (15.7 KB)

Thanks. For the next update (not today’s) I’m stripping out invalid XML characters from text runs which fixes this (and hopefully won’t cause any other issues - I cannot find documentation on characters that .docx explicitly considers invalid, but it’s an XML file so hopefully this is fine).