Downloads won't open (Mac)

When I first tried to download and open Scrivener 2.0. I kept getting an error message ‘Can’t open this Disk Image. Reason: Disk Image not recognised.’

I ran Disk Utility a number of times on both Repair Permissions and Verify Disk and eventually Scrivener opened and seems to be functioning fine (I’ll be upgrading at the end of the month).

This morning when I saw the offer on MacFamilyTree on MacUpdate on the Lit&Latte forum, I downloaded it and got the same message ‘Disk Image not recognised’.

I then tried to download Zipeg to open MacFamilyTree and voila same message again.

I’m not great under the hood of a Mac. Can anyone explain what’s going on and how I can fix it?

I’m on a MacBook Pro, about a year old and so far no other problems.



Someone else reported a similar problem as well, and it turned out looking as though something has become corrupted in their OS over time, relating to .dmg mounts. This can happen in a “spotty” fashion, meaning some DMGs work, others do not, and some that don’t work end up working later, or stop working later. In short it might be something to keep an eye on. If the problem gets worse, and spreads to DMGs from other vendors, you might consider doing a fresh re-install of your operating system. There is otherwise no good way to fix just this part of the OS all by itself.

Hopefully it either goes away or remains a minor problem for you.