Drag keywords back into documents.

Not sure if this is doable, but I think it might be handy.

I store a lot of place and character names in the keywords list, so being able to click and drag them into the current document would be very useful IMO.

I think I remember requesting this, or something like it, a while back and there is a technical limitation involved with dragging things into the text area itself. Oh, yes, I suggested being able to drag documents into the text area to load it, instead of just the header bar. That might be different.

Mmm … well, I can drag selected text from a note into the main document, so I was assuming that the same was possible with keywords; could be wrong though.

Well that trick is provided with the Cocoa class, I think.

Not a bad idea Rayz, and it should be easy to implement. This is a very different situation to what AmberV is talking about. AmberV wanted to open documents by dragging a document to the main document area, and I believe that she thought that you were asking if you could assign a keyword in this way, which would not be possible.

However, if I understand you correctly, you are just asking whether it would be possible to, say, drag the word “Bob” from the keywords table into the main text and have “Bob” be plonked in the text. This should be fairly straightforward. Added to the list for beta 4.

All the best,
Keith

Oh! Yes. :slight_smile: That is quite different, and that would be useful. Hey, could they be tab-indented to represent hierachy?

Uh… No. :slight_smile: Just a simple string copy. :slight_smile: Surely the main reason you would ever want to do this is to save typing a difficult or excessively long name…

Okay, Okay. :wink:

Mmm … that certainly is an interesting idea, but I’m not sure I see the need for it. Surely it is less work to just click on the document. It loads up anyway, without having to drag anything …

Mmm … no, that wasn’t what I was asking for.

No more, no less. No need for fancy tricks with keyword heirachies or anything like that. Just grab the keyword with the mouse, and drop it using the standard rules for drag and drop.

Thank you very much. That’s very decent of you; with any luck, someone else may find it useful too …
:smiley:

I’m under the impression that keywords cannot be added from existing text; is this correct?

The way I have been trying to use keywords is to add them to the Inspector either as I type (selecting the word with shift-option-arrow and using a hotkey) or after I have finished writing a text document (selecting each word in turn, and using a menu item or hotkey; or drag-dropping onto the Inspector keyword list). The keywords would then appear in the HUD, and I would then drag them onto documents in the Binder to apply them (thanks for adding that btw!).

Neat, I didn’t know you could select a word in the editor and press a shortcut to turn it into a keyword. Where is that command?

Er, you can’t.

I meant that was the way I was trying to use keywords.

Instead I have to mouse over to the Inspector and re-type or copy-paste.

Not a bad idea. It would be drag-and-drop if I add it, though, not using Yet Another Keyboard Shortcut. :slight_smile: Drag and drop should be easy to set up, though I am writing this at midnight after two or three glasses of wine, so if it turns out not to be so easy as it seems in my head right now, please do not shoot me if it doesn’t make it in. :slight_smile:

Drag-and-drop or a context menu item would be great; I agree there is an overwhelming number of hotkeys already.

Just remember, wine is for debugging, not for coding :wink:

And vodka is for logging in to the bug report list the day after uploading a new beta.

DragonDrop from the Keyword HUD into text appears to work as of 1.01, but there is a gotcha: the insertion is not UNDO-able. i found this out by trying to drag a keyword from the HUD to the inspector, but mouse-bounced en route, thereby dropping the keyword into the text. i tried UNDO but nothing happened. i dismissed the HUD and still not UNDO-able. i had to manually highlight the text and then delete it.

certainly seems to violate the “Law of Least Amazement”

but overall, Scrivener is quite a stunning achievement

    -mo

Actually it is undoable, but you need to ensure that the text view has the focus. This is because there is more than one undo stack in Scrivener - the text has a different undo stack to the keywords HUD/inspector, so you need to click into the text before hitting undo.
Best,
Keith

Hi,

the multiple undoes of Scrivener are a blessing as well as – not. I am quite often puzzled about why there is no undo and look for the right view to enable the undo I wish.

So I thought, sitting silently and isolated on this remote island, how nice it would be to have the Edit menu with several undo-menu items like “undo edit synopsis”, “Undo Edit Text”, “Undo rename Binder document” etc. …

At least it would be helpful to know which kinds of undo-stacks Scrivener deals with so that my searching for the right undo-Stack would not be so wild and unsystematic.

Otherwise: I am quite silent recently, don’t you think so? Well, I am writing… :slight_smile:

Maria

There are actually only two real undo stacks - the one connected with the text of a document, and everything else. So, if an action affected the main body of text, you need to click into the text to undo it. If it affected anything else, make sure you’re not in the main text. I can understand the confusion, but having undo associated with each body of text I think is definitely desirable.

And yes, you’re right, you have been quiet. It’s about time you started making suggestions that I can say “no” to again. :slight_smile:

Best,
Keith