Drop down options won't work and typing laggy

No other programs on my computer are acting up, just Scrivener. It started about three days ago where, in the middle of typing, Scrivener will suddenly start going unbearably slow trying to keep up with what I’m typing. When I try to close the program, it won’t shut down. And when I hover over “file” or “help” options, it will only show a see-through outline of the drop down menu, but none of the actual options. However, when I click blindly, the option is chosen (for instance, if I happen to click where I think the “save” option is, it will save the file for me).

It goes back to normal after I restart my computer, but after awhile of writing, each night, it starts lagging terribly. It does seem like it would be a problem with my computer, but every other program on my computer is running smoothly and just fine. As I type this, Scrivener is stuck open, refusing to shut down When I open up task manager to try to close it faster, it doesn’t even appear there.

It’s always worked just fine for me previous to this. It’s a problem that only just started a few days ago. Anyone else having these issues? Thanks.

Hello Reisara,
Have you tried the all time cure for dodgy programs, acka uninstall and then a fresh installation? Can very often clear a problem where a program may have become corrupted. This should not affect your back ups or save work. Adjusting the Save after a period of inactivity under the Options / General setting helps to improve response although your problem seems a bit more than just slow response.

Thanks for the quick reply! I did try that just now. Unfortunately, the problem remains. Could it possibly be related to the Scrivener update I installed just recently? Is there a way to go back to the previous version?

Yes, you can download the previous version from this site. Click on the version number where the download is (little blue figure) or just use this link to the previous version

literatureandlatte.com/scriv … sion-1_9_6

Bearing in mind the current version is 1.9.7