'Duplicate' command duplicates the wrong document

This is a tricky one to describe, and even harder to search by keyword — I searched the forums but found nothing.

When I use the ‘duplicate’ command to duplicate a document, the title is duplicated correctly but the content is taken from another document in the same project. Also, the content that’s duplicated is never from the same document.

This, along with the fact that a few settings have changed (e.g. corkboard font, card size), seems to indicate corruption in a project file.

I was away for a few weeks, but nobody used my project or Scrivener in the interim, so nothing has changed except the calendar year. This problem never occurred before I went away.

Unfortunately I cannot provide my Scrivener project for testing, as it contains business-confidential information. Beyond that, I will certainly do whatever I can to assist.

A few extra facts which may help:

  • WinScriv v1.0.3 (Win 95), still in trial period
  • I may have opened the file at home (MacScriv v2.2, full licence), but if so I have definitely opened it in Windows since, and with no problems
  • The file contains tables (I have had problems with table formatting; see here)

Many thanks,

I checked my duplicate and it is working perfectly.

Make sure you are right-clicking the correct document.

Do you notice a pattern? Like is the duplicated text always from the above document or below document?
(From the document you are trying to duplicate…)

Try opening a different project and see if the same error occurs. If it doesn’t, I would seem to be a problem with that particular project.

Thanks for your reply.

The duplicated text is from a different document every time, seemingly at random (although the order of the documents in the binder/corkboard does not indicate how the documents are indexed or sequenced internally). The title is always correctly taken from the document I want to duplicate.

It’s definitely unique to this project. No others are affected.

Also, this problem happens whether I select ‘duplicate’ from the index card’s context menu, the binder’s context menu or ‘documents -> duplicate’ in the menu bar, so it’s not a UI issue.

I went home and opened the project in MacScriv. Immediately it popped up a message about the need to recover some files (I wish I had taken a screen shot!), then opened the project normally. Document duplication worked, and the recovered files were indeed missing from my project.

This morning, back at work, I’ve opened the same project in WinScriv to find that document duplication now works correctly here too.

So, it looks like corruption after all. I suppose this thread now becomes about (a) what in WinScriv caused the corruption and (b) the fact that WinScriv didn’t offer to recover any files (a future feature?).

It’s too late to check now, but I suspect WinScriv was moving existing documents when I asked it to duplicate a document. Why? Because I lost quite a few documents that were never recovered, and the number of lost documents is roughly the same as the number of times I hit this duplication issue. Every time WinScriv duplicated the wrong document, I deleted the duplicate; in hindsight, I think it was deleting a different document each time.

That would explain why the duplicated document was different every time, and it would explain why I lost a load of documents that were never recovered.

Am I making sense? This sounds like a whopper of a bug, so I hope my descriptions are clear.

Edit: Five days later, it has just occurred to me that not once did I mention the word ‘Dropbox’. This thread helped clear up a few things for me — perhaps not the cause of this problem, but certainly something every multi-platform Scriv user should know.