Duplicate punctuation after import from .docx (also...non-breaking space help?)

A few months back I exported my project in individual chapters to take advantage of another program’s revision features. Several drafts later, I imported it back to Scrivener today to do a final compile into a single document.

What I noticed in this process is that Scrivener duplicated occasional marks of punctuation–apostrophes, quotation marks, em-dashes…who knows what else that I haven’t seen yet.

To say this is frustrating to discover in a document I have just spent months editing the daylights out of is an understatement. What gives?? Anyone else ever encounter this? I know they are not my own errors, because I can go back to those originals and the duplicate marks do not exist there–only in the Scrivener files and now my compiled 76,000 word .docx. :confused:

UPDATE: Searching the web in more detail (all about finding the right keywords…) I discovered it was something to do with having imported in .docx rather than .doc. I went through the process of resaving all my files with the older extension, and that does seem to have done the trick. But is there something in Scrivener itself that I should tweak so this doesn’t happen again? It seems a bit odd to be reliant on extensions that are over a decade old. I’m sure I’m just missing something, but I don’t recall seeing any options when I imported.

UPDATE 2: I also cannot get non-breaking spaces or non-breaking hyphens to work properly. I can’t even find how to insert the nb hyphen in Scrivener, though I thought I had the space, but it doesn’t seem those were honored…or if they were, they reverted to simple spaces when I compiled into a .doc. I did find an older thread on here discussing it as an apparent ongoing known issue, but that was several years ago. Has a fix been found yet?

Thanks. I’ve spent hours trying to hammer this out tonight and now I’m cross-eyed with exhaustion. L

If you have Microsoft Office 2007-2013 installed, you can switch DOCX import converters to avoid the duplicated punctuation issue that can occur with the standard converter. In Scrivener, go to Tools > Options > Import/Export and click “Import Converters…”, then select “DOCX” from the dropdown menu on the left and “Microsoft Office” from the menu on the right. That won’t fix it for anything already imported, but it should avoid the problem in the future. If the MS Office converter isn’t available, you’re best off sticking with RTF for the import. RTF is Scrivener’s native format and is usually the best option if you’re having trouble, as it doesn’t require a huge conversion.

Scrivener does not currently support non-breaking hyphens in the editor, although you can use the compile replacements to add them to the compiled document by pasting the U+2011 character from the Windows Character Map or a plain-text editor like Notepad directly into the replacements “With” field. (You’ll need to use a font for the compiled document that includes that character.) You could also do this by adding zero-width word joiners (U+200D) on either side of the hyphens in compile replacements. Non-breaking spaces can be inserted in the editor via Edit > Insert > Non-Breaking Space or using the shortcut Ctrl+G, Ctrl+W (hold down Ctrl, type G, type W, then release Ctrl). You can change the shortcut in the Keyboard settings of Tools > Options if you use these frequently and want a simpler shortcut. The spaces should be preserved when compiling to RTF, DOC, or DOCX if using the Microsoft Office export converters (also set in the Import/Export options, as above).

Hm. I have Office 365, which is currently on Word 2016. When I follow these steps, the only options I have in that right-hand box are “Doc2Any” (not a clue what that is) and Scrivener. Does the feature not work with the newer versions of Word, even though it’s still *.docx?

Thank you for the hyphen and nbsp tips. I did try the Ctrl+G, Ctrl+W trick, but it did not seem to be preserved in conversion…perhaps again because my version is unsupported. :frowning:

Currently support is only through 2013, but we are working on adding support for the non-subscription (Home & Student and Professional) versions of 2016 and hope to have that available in the next update. Unfortunately, the conversion tool we have does not work with the Office 365 APIs. We are planning to change to a different tool for creating/importing DOCX in the next major version of Scrivener, so this won’t continue to be an issue, but for now you may want to stick to using RTF. That will also preserve the non-breaking spaces during compile and can be resaved to DOCX from Word.

Hm. Okay, I guess that explains it.

Oddly, I do not seem to have RTF file type options on import/export converter settings. For Import, all I have are DOC and DOCX via Scrivener and Doc2Any; for Export, I have DOC, ODT, and PS via Doc2Any and RTF-Based.

The formats listed in the Import/Export options are just those that have multiple converters available on the machine. RTF conversion is built-in without alternative tools–the main conversion is just to handle Scrivener-specific features like inline annotations and footnotes–so there’s nothing for you to choose in the options. When you go to compile, RTF will be listed in the “Compile for” formats near the top. Likewise you can just select an RTF file for import or drag it into the binder without needing to specify options first.

Ohhh. Ok, I understand now. Thank you!