eBook Compile Issues

You have compile issues filed. Just making sure the following are included. With the eBook format in Compile:

  1. The first paragraph of both Group and Text are not indented. Even if you edit the layout to set the first line indent and save your change, it reverts to the first paragraph not being indented. It doesn’t matter which layout you use; they all do it.

  2. The table of contents is always placed before everything else.
    a) That is different from a random sampling of Kindle books that have the title, copyright, dedications, and more before the TOC.
    b) The title page, dedication, copyright, or whatever pages you use for the front matter get listed in the TOC.
    c) Even when you select only the chapter layout without a title, The title is appended after the chapter number in the TOC. The only workaround is to leave all chapters/folders untitled.
    d) The help bubble for the Table of Contents Title field (on the rightmost icon in the compile window) says specifying a title that matches a compiled document will use that document as the TOC. That does not work.

Thanks,
Miik

In section layouts, in Formatting, the checkbox at the bottom: “Override text and notes formatting” – is it checked? Yes? Uncheck that. I don’t have this issue, and that box is unchecked (it’s checked by default). When it’s checked the text in the Formatting box is formatted as you’re experiencing. When it’s unchecked, that goes gray.

Even with those boxes for Chapter and Section Text unchecked, I still have the first paragraph not indented.

I confirmed that in my text to be compiled, the first paragraph is really indented.

I’m using the default CSS. Are you? The issue in the resulting file is that the first paragraph uses the paragraph tag class=“scrivener14” which has no indent. All the other paragraphs use the paragraph tag class=“scrivener15”.

I’m using Kindle KF8/Mobi as the eBook setting since that was the default. When I switch to others, nothing seems to change with the layouts.

Have you compiled with beta 17? Do you use styles in your text? I didn’t since it’s just plain text.

Thanks,
Miik

I wasted so much time trying to create a .mobi file for upload to Kindle Direct Publishing, but still couldn’t get the file right. Then I found a simple solution. I downloaded Kindle Create. It is free. To use it, these are the steps.

Compile to a Word docx file. Set the compile to format the manuscript as you would like it to look in an eBook. Forget page headers and footers. For the front matter, I used one document (Structure Based/As Is) with the title and byline, inserted a page break, the copyright notice, inserted another page break, and finally the dedication.

In Word, I had to highlight each chapter title and set the style to Title even though I set the style for chapter titles to Heading 1 in the compile.

Use Kindle Create to convert the Word file. It will give you a chance to review the chapters for the table of contents. I deselected the title page, the copyright page, and the dedication. Review it just as you would in Kindle Previewer 3. Right click a page in the list on the left, such as chapter one, and select to insert the table of contents it created. You can also apply a theme if you want. Save it as a kcb file if you want and publish it as a kpf file ready for uploading to Kindle Direct Publishing.

Thanks,
Miik

Interesting. I’m using the default epub format in compile, changing nothing except the one checkbox.

I use Beta 17. I do use styles, but mostly I stick with “no style.”

Interesting. Scrivener by default does not indent the first paragraph (you can see this by looking at the Assign Section Layout layouts).

I did not change the CSS at all; the CSS box says “section.”

I’m publishing to epub, not to mobi (don’t really want to install the mobi-izer from Amazon), however.