Edit menu in S3 opens when I touch my MacBook Pro Touch Pad

When I want to delete a text passage, for instance, in Scriverner 3 on my MacBook Pro (OS 10.14.4), the Edit menu almost always pops up the moment I touch the Touch Pad and before I can do anything else. How can I stop this from happening?

Very odd. Tried rebooting the Mac and / or reinstalling Scrivener? Has it always done that, or just recently?

Slàinte mhòr.

Jo–I need to clarify by sayin when I press (not touch) the Touch Pad. It’s been happening this way for sometime, perhaps since I installed S3. I usually work on my old iMac with S2, so have put up with it the few times I used S3. If no other suggestions come, I’ll reinstall S3.

Never heard or experienced anything like it, thankfully. Hope someone can offer a solution. Don’t think it is a Scrivener issue as such, but I guess anything is possible.

Good luck.

Slàinte mhòr.

Are you using two fingers when pressing the trackpad?

If you are not using two fingers, then the rest of this post is irrelevant.

If the two finger gesture in the System Preferences’ Trackpad pane is activated then pressing with two fingers will cause this. There are two possible solutions.

First solution: turn that option off in System Preferences

Second Solution: Avoid using two fingers when pressing the trackpad.