Edit Scrivenings --- Full Screen

  1. I choose four or five index cards.

  2. Then I choose “Edit scrivenings” “Selections”.

  3. Then I choose “Full Screen”

  4. Then ---- nothing happens. A little window shows up saying “Loading text… Please wait…” and stays forever. I have to quit S to resume working.

This doesn’t always happen, maybe 50% of the time.

Best,

R.
Bild 1.jpg

Hi,

there was the same behaviour on my G4 iBook yesterday. I chose the documents for EditScrivenings in the Binder and changed to Full Screen.

I did not think of a Scrivener bug but more of fatigued machine after 23 million hours or so uptime. But the description is identical.

I stopped Scrivener after a while (cmd-opt-esc) and restarted the computer. This was the only hanging in 32 million or so times I change this way to Edit Scrivenings and then full screen.

Maria

PS slight exaggerations in this post? Never mind!

Indeed! These numbers would date your computer at 600 B.C. give or take a few decades. I think you were right to restart your “computer,” but you really ought to look in to upgrading it.

O, I got so used to the fine pink marble, and just 20 or so years ago I replaced the sticks that count, excellent dry oak, I can easily rearrange them when doing my calculations. Should I really — upgrade???

:cry:
Maria

Bronze is the big thing right now.

Please check out Console.app when this happens to see if any errors are getting written out. I have never experienced this problem myself and cannot see why it would happen on five index cards, even with long texts…
Thanks,
Keith

Keith,
I will do so, if it happens again…

Khadreit,
your posts are always exactly what I like to hear :laughing: . Bronze, that sounds good. I will have a look when I canoe to Tokyo next time.

Best,
Maria

Always happy to share useless observations. :wink:

Belgian characterstic?

http://www.youtube.com/watch?v=Wd44XTlUQjQ

http://www.youtube.com/watch?v=YimXbKpmfSM

I think it is on Belgian TV… Wow, I still cannot breathe…

Maria

It happened again.

This is what console says (whatever this means):

Mac OS X Version 10.4.9 (Build 8P135)
2007-06-14 05:28:27 +0200
Jun 14 05:28:28 localhost /System/Library/Extensions/IOSerialFamily.kext/Contents/PlugIns/InternalModemSupport.kext/Contents/Resources/AppleModemOnHold.app/Contents/MacOS/AppleModemOnHold: MOHServiceAddedProc >>\n
SoftwareUpdateCheck: network unreachable
2007-06-14 05:28:29.809 loginwindow[74] FSResolveAliasWithMountFlags returned err = -43
2007-06-14 05:28:31.350 SystemUIServer[100] lang is:de
2007-06-14 10:29:07.553 SyncServer[330] tossing reply message sequence 1 on thread 0x306db0
2007-06-14 11:45:50.244 Scrivener[325] *** NSRunStorage, _NSBlockNumberForIndex(): index (20815) beyond array bounds (20812)

Okay, that is a text bug (in Scrivener, probably).

Is this happening with a particular document? Can you get it happening every time? If so, can you please send me the project with a description of how to reproduce to support@literatureandlatte.com.

Thanks,
Keith

Sorry, can’t get this to happen purposely. Tried many times now.
I will try to discover if this behaviour is limited to just a particular project or if it occurs in all projects.

Best,
R.

Keith, I think I can reproduce it now.

Mark a number of index cards.

Merge the text with edit srivenings.

If the text at its end has blank lines and you move the cursor there into this blank space and you hit alt-apple-f for full screen you will get the little window that asks you to wait and will not go away.

Well, at least, this is how I can reproduce it on my G4 iBook (1.2 GHz, 512MB DDR SDRAM).

Best,

R.

To be more precise:
move the cursor all the way down into the very last blank line. This will on my computer trigger the bug.

Thanks, rochefore… Hmm, I still can’t reproduce this. Which version of Scrivener are you using? What preference settings are you using (full screen etc)?

Thanks,
Keith

Hi,

since I have encountered the same problem once and mentioned that earlier, let me just add that I also cannot reproduce it.

Maria

Sorry, just to update: I know exactly what the problem is thanks to the files sent to me (it only happens if you have scrivenings separated by double newlines in preferences), and I will fix it for 1.1.

Thanks!
Keith

i have he same problem.i hope i can find the right answer at here.Who can tell me??? :question:

This was a bug that has been fixed in an update. Which version are you using?

Keith I’m not sure if this is a related thing or not, but I can’t get a multiple selection Edit Scrivenings session to appear in Full Screen at all - I just get the first document. It’s the same whether I use option command 4 or the menu button.

So I select some files and it goes to the corkboard view (not sure how to avoid that) and then I press the Edit Scrivenings button, and the Edit Scrivenings works fine, then I go to full screen (using either Option command F or the menu bar button) and there’s only one document.

It doesn’t matter if I Lock in Place or not. The Option command 2 version of Edit Scrivenings - on a folder selection - still works fine.

Nothing is appearing in Console.