Editor font change and save it to default?

Sorry about stupid question but I just cannot find a way how I can set Courier 14 as a default font for ALL projects and all texts by default? If I set it from Editor and create a new file then next project still have Cochin as a font.

Help? :slight_smile:


You can set this in the “Formatting” pane of the preferences (the top “Main Text Style” box in that pane allows you to set the default formatting for new documents).

All the best,

Thank you very much! I just don’t understand how I had not find it…


Font settings don’t seem to work all the time. I still see some new text items open as Cochina by default, even though I changed the default to Helvetica. I’d like to see this fixed.

There are no known bugs here - this has been working well for five years or more with not a single bug report. Perhaps you could provide more information so that we can help troubleshoot what is going wrong for you? It could be down to a corrupt preferences file (but doesn’t sound like it) or a setting somewhere, but it’s difficult to say without more information.

What I think is not clear is how you set the font in the ‘Main text Style’ box. Instead of using a font selector like the FOUR others on the page it uses a different mechanism entirely. You have to put your pointer over the box and right click to get an option box with a fonts selector. This is a wholly inconsistent UI design to use two different font selection methods on one page.

Because the main text style box isn’t just for setting the font - it is for setting all the formatting, including line spacing and suchlike. The “A” icon is standard on OS X to represent font.

On a related note, I have no trouble setting the “Main Text Style” in this way, but I am having trouble trying to configure the other text style options, e.g. Title, Heading, Sub-Heading … even Body.

For example, if I set the Main Text Style to be 18pt Regular of some font, converting the document to Default Text Style, dutifully changes things to 18pt Regular. But if I then select some text and choose Body from the style options, the text goes back to 12pt (though the font doesn’t change). If I then convert the document to Default Text Style again, the affected text jumps back to 18pt.

I may have misused some technical terminology there, but hopefully it is more or less clear what I am describing … Essentially, I want to be able to define Heading, Sub-Heading, Body etc. to behave like I want them to :slight_smile: and I can’t quite figure out how.

The presets button containing “Body” etc is just a list of preset formatting that you can apply to text. It appears in the formatting bar wherever it is. When it appears above the “Main Text Style” area in the Preferences, it allows you to apply preset formatting to the main text style, just as the font button allows you to apply different fonts to it. To edit the items inside the presets menu, you need to set up some text in the main editor (not the preferences) with the style you want them to use, select the text, and use the Format > Formatting menu, either redefining an existing preset or creating a new one. This is very much how Pages works with styles (although formatting presets in Scrivener are not true styles, since they don’t update throughout the document; they are just a collection of formatting presets that can be “painted” onto any existing text).

All the best,

Ah! Thanks for the explanation. :smiley: I kinda figured there must be a simple fix that I simply wasn’t getting, and I figured it must be related to how things work in Pages (though here the problem is that I don’t really know anything about Pages). Anyway, that seems to have solved my issue – insofar as it is possible to solve with the way Apple has set up its text/style handling.

For what it’s worth, Word’s style are kinda lame from the point of view of what one can do in Framemaker or even Mellel – but that would all be wildly overkill for Scrivener’s purposes anyway. :slight_smile: Being able to set up those very simple heading/body/quote etc. styles for my own purposes in a “research” (as opposed to “draft”) Scrivener document is useful, though. :slight_smile: