Editor Header font not alterable

Hi, niggling question, but the font change options for the Editor Header are greyed out on my windows version 3 and this is stuck on Segoe UI size 19 which is just frankly bumming me out. Never had this issue with previous installations (new installation since a hard drive failure 3 months ago). Any ideas?

The font settings in the editor will be greyed out till you click inside the editor document. Once you have clicked inside you should be able to change the fonts to whatever you want.

I’m not sure what exactly you mean by “editor header font”, but here are two places where you can change the font for “top parts” of the editor.

image

image

Yes clicking in the editor means the font options are no longer greyed, but of course I can’t then change the header (title) of that particular document itself. Clicking in the header then greys out the font change options, but thanks!

By Header I mean the title of the document as it appears in the editor (not binder). Unfortunately none of the options you suggest seem to make a difference. As soon as I click into the header, font options grey out, and none of the option changes that I’ve made seem to make a difference. Thanks for you time though!

On a Mac, if I understand the issue correctly, that would be:

  1. Scrivener

  2. Preferences

  3. Appearance

  4. Main Editor

  5. Fonts

  6. Header Bar [set font and size as desired]

Same for Windows?

Apparently not on windows (or at least my version?) there is no font option under main editor in appearance - only options (margin widths) and colours! thanks, though!

1 Like

To clarify, as you tagged this post with “text-editing”, which none of the above configuration settings would have anything to do with—are you thinking that this text in the header bar is formatted, as though it were a part of the main text editor below?

If so, it’s not, it’s just a text field, like when you click on an item over in the binder and press F2. The editor header bar is just another way to do that same thing, for cases where the item you are editing isn’t visible in the binder. So that’s why formatting stuff would be greyed out, and it has never worked any other way, in any version of Scrivener, and if it did, it was a bug and the changes made to formatting never would have stuck because there is no formatting in this text field.

But if you are talking about configuration of the user interface, and the tags are incorrect, then indeed the setting for this has not been added to the software yet.

1 Like

Thanks for this Amber. As is probably clear I wasn’t sure how to tag this post and so chose what I thought was closest to. I don’t seem to be able to post a screenshot to this forum which has unfortunately no doubt wasted the time of the generous individuals who have responded to this query. I’ve used Scrivener for over a decade now (albeit with no particular knowledge of its intricacies) and I’ve never had the text in the header bar appear so large before! I appreciate that this really is a trifling concern, but I’m a trifling man… I have also noticed that occasionally right clicking on items in the binder also results in these appearing with an absurdly large font (and therefore not displaying all of the options). Perhaps this is just an odd glitch with my most recent installation and I should just reinstall?

Could perhaps be a Windows’ setting.
Something related to “ease of access” maybe.

No worries! It can be hard to describe things if you don’t know what all is something that can modified or not. I’ve adjusted the tags accordingly.

I think what Vincent_Vincent posted above might be the right direction to look into. I’d also check the font scaling settings in display settings. I think there are some areas where Scrivener leaves the font size up to the system, and unusual settings can cause blown out text in the UI (or stuff really shrunk down, as the case may be).

Aha! yes, indeed it is a windows display issue. Specifically, if I unplug my second monitor and then plug it back in without restarting my laptop, scriv uses the 250% magnification I have on the laptop screen for my main monitor. I’d been dealing with this by just dragging scriv from the monitor to laptop screen and then back again - which reset the font size back to 100% for everything except the document header in the editor. Thanks so much!

Thanks Amber, issue resolved (display setting-monitor unplugging-thing), not scriv per se. cheers.

1 Like

I am having a similar issue, but it is not a monitor display issue. My header bar font is super tiny. Just the header bar font, not anything else. Scrivener 3 for Windows does not have an option for font for the Main Editor like it does in macOs.

This is mostly likely caused by Scrivener interacting with your display settings.

My usual display setting is 1920 x 1080, with 100% scaling.

Looks like this:

But if I change scaling to 150%, the header bar font becomes tiny:

So my guess is you have a high resolution monitor, and to compensate you’ve got scaling set high?

If that’s an accurate guess, try tweaking your scaling to see how it impacts things, perhaps you can find a lower setting that improves Scrivener and still works for you in other areas.

Best,
Jim

1 Like