Editor inserts an extra period

When I am writing dialog and I have a sentence like “Hello there.” The editor automatically inserts an extra period after the quotes. So, it looks like “Hello there.”. It would be really nice if the editor recognized that a period was inside the quotes, so we don’t need a period outside of the quotes.

Which Script Settings do you use? I tested few of them but could not reproduce it. It could also be triggered from some of your custom auto-complete combinations. If you upload a small test project with a dummy document showing the problem, it will help us a lot reproducing the problem. Thanks!