Editor typing lag - Is it meta-data?

Hello again! First time sitting down and actually writing with Scrivener 3 and I’m experiencing severe lag in typing/display. As it stands now, Scrivener 1 has no lag with a virtually identical project file while 3 is borderline unusable.

The problem is exclusive to my imported Scriv1 project, which admittedly is large, so I tried to isolate what might be bogging the system. To rule out the case of too many files, I tested importing files from my project into an empty project (thereby stripping everything of meta-data) and I was surprised to find the lag was not present. Subsequently adding (albeit empty) meta-data columns does not reproduce the problem, though.

It takes a long time to process setting changes to meta-data in my project, so I wonder if I should take it easy on the meta-data to improve performance? Is this a plausible course of action? Anybody aware of other causes of typing lag in Scrivener 3?

Details: In Scriv1 I used 8 text meta-data fields, with 4 being used frequently. After my Scriv3 import I added 2 (one checkbox, one dropdown) with the intent of deleting 2 obsolete fields after a transition. My aging Windows 10 is probably a hinderance, but again Scriv1 can handle it just fine.

1 Like

Small update - emailed devs, but in the meantime made a copy of the OG file and converted it again for dissection. I wiped it clean of meta-data and it’s still lagging! Weird. I can’t figure out what the culprit is. I guess it must be something in my project file because Scrivener 3 operates normally in every other instance.

Also wanted to add that (I think) I ruled out antivirus as a cause. Should be whitelisted.

:face_with_raised_eyebrow: Color me skeptical, but when it comes to antivirus (AV) I’m always suspicious.

I’d worry, that just because it is whitelisted, it doesn’t mean that AV isn’t gobbling up resources looking at it. Whenever my machine starts running slow, it’s usually one of two causes: AV (the usual cause), or I have left my browser up with too many tabs open.

Not very helpful, I know. Sorry about that.

YMMV,
Micah

You might be right here, because even when I temporarily disable my firewall, the process is floating around when I’m using Scrivener 3. But I don’t want to have to shut down my AV completely! Is there even another half-measure available? (And yes I’ve also tried opening Scriv3 alone with no chrome or other programs too.)

For what it’s worth, I have been using Webroot anitvirus for years and have not had any problems with Scrivener and almost all other programs. It’s light and unobtrusive, but keeps out the garbage. So you may want to consider switching AV products if the one you have keeps causing problems.

1 Like

From what I have filtered out of this discussion so far is that it could equally well be a problem with the available main memory. I had all kinds of such problems with various applications having only 4 GB installed on my Win 10 system. Upgrading to 16 GB made so many things way faster! Watching the swap rate in Task Manager might give you clarity in this regard.

Since I’m not savvy enough to know the lingo, which stat in task manager monitors this? I’m having trouble getting a straight answer from Google.

In Task Manager select the “Performance” tab. Then select the disk drive where your Windows and programs reside in the left column. If Windows needs to swap parts of your programs in and out because of lack of main memory, you would see increased disk activity here.

How many GB of main memory does your machine have?

2 Likes

I see it now, thanks for taking the moment to explain! :pray:

I’ve got 932GB. I’m typing on Scriv3 side-by-side with the chart to get a response… it’s usually under 1MB/s, I can occasionally provoke it to 7-10MB/s by typing in the editor, but it’s not quite reactive enough for me to be sure of the correlation.

I also operate from my OneDrive folder and I have tried pausing sync to see if that interaction was causing problems. It didn’t, but I’m going to open it on my C: next and see what happens.

1 Like

OneDrive is NOTORIOUS for both creating lags and eating up your CPU power. How fast is your internet connection? You may want to work with a local save and then sync it periodically to OneDrive.

932GB is going to be your harddisk space, not your memory. If it were–color me green with envy.

What I hopped on here to say, I’m also working with a very large file. Which did lag a little bit at first. If your PC comes with game mode, add Scrivener to it. You are then giving it priority in using resources, and it will run faster. It will also open faster.

As for the rest I’m with the others, look at your antivirus. Most of the time AV is the culprit.

A dev suggested running safe mode (network) presumably to confirm it is some interference by AV or some other program. Plot twist… it’s none of those things, because the problem persists in safe mode. So, it seems like my issue is something else (if I understand the experiment correctly).

I’m still stuck on the fact the problem is only persistent on my big project file. I’m thinking something in my binder/data is bloating the software. It’s just that I’ve ruled out what makes my project unique - it’s not too much meta-data, it’s not too many files, it’s not my scriptwriting settings… I’m stumped, and I’m not seeing other people with the same problem.

Trust me, my dude has been with me for 6 years, it is worn and hardly envious! I have 8GB of memory, 8.6/12.9GB committed, 1.3GB available, if those numbers help communicate my computer’s condition. As an aside, good chance my computer’s incompetence is the issue.

If this was me, I’d keep the task manager running at all times. It is then clear what is active and taking up your memory.

8G ought to be plenty, depending on what else you have running.
Did you remember to change the boot options before you did the safe mode test? You want only the required services to run.

Anyway, task manager should give you a decent clue.
I would also recommend that you hop on TenForums.com with your issue. It’ll be a far better place to post logs etc., than here.

Your rabbit-hole may include anything from a virus to outdated drivers, or something as simple as too many programs running at the same time.

I swear the Windows 10 store gets money from the telecom folks, worst piece of bloatware ever invented. So one place to go is to turn off everything running in the background from the windows store.

Your last paragraph shows your problem. 1.3GB available, 8G installed and TWELVE G committed. You’re running a sizeable swap file, so yes–things will be slow.

  1. Virus scan
  2. Hit TenForums, get instructions on setting up selective start-up and turn off all bloatware running in the background.
  3. Defrag
  4. Clean-boot with NO extraneous (to Windows) processes running, with network support. The folks at TenForums are awesome and have step-by-step tutorials. Note what resources are available with only the OS running. Then load your programs (manual start) one at a time, and note the difference in task manager. You will soon have your culprit.

TenForums rock for this.

Hope you get it sorted.

PS: I added Scrivener to gaming mode, and it made all the difference for my huge file. My rig is 6-years old, with a nearly full harddisk and loaded with all kinds of hungry programs.

Anyway, best of luck, hope you get it sorted.

1 Like

Wow! You gave me a lot of new advice, it’ll take me a while to get through it. Thanks for your thorough insight, BadScribbler!

You know, I looked into this when somebody else advised me to try it, but for me, “game mode” is an on/off setting for my whole computer (already switched to “on”), so I’m not sure what it means to “add” a program to gaming mode.

1 Like

TenForums will walk you through it, or just type game mode into your Windows Search bar and follow the links it gives you.

In order for a program to be in game mode you must add it.
Unfortunately W10–because of Microsoft’s diabolical sense of humor–moves things around in the OS with every update. SWELL.

Don’t you just LOVE Microsoft? Anyhow, in 10.0.19041 (I’m on the corporate update cycle to let the oh-so-funny BSOD [Blue-screen-of-death] issues work themselves out before I go there); settings–>gaming–>game mode: Click graphics settings in the RH upper corner, and under graphics performance preference, choose desktop app, hit browse, and find the scrivener EXE file. Be sure to follow it through the shortcut to the EXE file’s location though.

You can find it via start menu, RH click–>more–>open file location. Then, when it opens, RH click the shortcut, and click “open file location”. Copy and paste the address to an empty notepad, in this example: C:\Program Files\Scrivener3. Note–this is the default location but your program address could be different, depending on how you have your system set up.

In any case, paste the address you copied into the notepad into the Windows Explorer window you’ll get when you hit “browse” in the Graphics setting app. Navigate to your scrivener EXE file, click it, click the “add” button.

Then when you see it below the graphics performance header, click options, then click the high performance radio button. Leave the variable refresh rate alone; unless you also like to play high-resource games which do not manage their refresh rate well.

Hit the back arrow in the very tippy-top left hand corner, flip the game mode slider to “on”, and you’re done. Scrivener should run much better.

However, in your case, you need to get a handle on that ginormous page file of yours. Anytime you are regularly running with more than 50% of your installed RAM committed, you’re going to have problems. Processor overheating being one of many.

TenForums have saved my bacon more than once… so you may want to hop over there and ask a question.

2 Likes

Another way to assign Scrivener to game mode is to start Scrivener, then click the Start Menu to open it, then type Game Bar and select Xbox Game bar. When it starts, click the gear on the right to open the Settings. Click the General tab if it isn’t already selected, then check “Remember this is a game.”

2 Likes

Thank you BClarke. I didn’t know that, even though gaming is among my procrastination activities.

Well friends… not to throw a wrench in our investigation… but even in startup mode with all services disabled and 6GB memory free, and even with game mode activated… I still have the lag. No discernable process flies to the top; my CPU jumps to 25% when I type, but it’s all Scrivener. Nothing else of note running.

To add more intrigue, I went ahead and installed a Scriv3 trial on a different computer (similar specs, but memory is a more promising 10.8/23.9GB) and loaded up my project file… the lag persists!

My computer’s memory does need serious TLC, but I’m starting to get a little skeptical this issue is a problem with my system . I can’t justify what about my project file would case a swap/processing issue, but it seems to be the case.

To reiterate, the only time this lag occurs is with my converted OG Scrivener project. It does not occur with a nearly-identical fresh project with all my files imported (not useful to me since it strips meta-data and other important settings). Other instances of Scrivener 3, no issue at all, I have no lag. Scrivener 1, no lag.

Anyway, I will be AFK all weekend, but I’m pretty invested in finding a solution (big time Scrivener user/fan here), so new ideas are welcome - I’ll be back. Hoping to hear if somebody else is having this issue too, maybe we can find a common thread.

1 Like

If I was a poker player, I am not betting on Scrivener being the problem at all.
Because of your page file. 15G (23G - 8G installed) virtually is a LOT.

With 2G taken up and 6G left over on a clean boot, you know that the other apps are using up the 6, plus another four–, or in the latter case 15 gigs.

If your system commits 12G and you have 8 installed, you do have a problem. If you have a 15 gig pagefile you have a worse problem. No matter what is running or not running. If that was me, I’d get a handle on that no matter which app looks guilty.

Clearly though, we would need to see your system details. TenForums is rim full of bored computer scientists itching to help, if it were me, I would go there–regardless of if Scrivener is guilty or not.

CPU’s are expensive to replace. And become obsolete fast.

Please believe me when I tell you I don’t have a dog in this fight, it won’t offend me one bit if Scrivener is gobbling up 21 gigs of RAM on your system. I’d be surprised though.

The heftiest apps I have (video game, Visual Studio) don’t come close.

But, installations can become corrupt, files can become corrupt, and so can metadata.

No way to know for us without seeing specs. At this point, maybe ping admin, give them a link to this thread?

And please let us know how you fare in the end. It could be valuable for another person if their file becomes corrupted. (If that is the case with you).

Very best of luck to you.

You’ve already identified where the problem is.

Contact technical support directly and get them a copy of your OG converted project so they can investigate and see what is causing the lag in the converted project. If you don’t want to send them the full project, take a few minutes to copy it and strip down the copy to the bare minimum necessary to display the issue. You can also run some project-wide search and replaces to obscure all of the text so you’re not revealing your work, if that is a concern.

If they have something like that to chase down, the devs may be able to release an update that will work around/fix this issue and help other Scrivener users.

If you don’t want to do that, you should prepare yourself to take the time to finish transferring the metadata, settings, etc. into your new project.

This may be my next move, thanks. I can run a wildcard replace and turn my project into a long and impatient scream… aaaaa a aaa a aaaaa aa a aaaa

Don’t get me wrong, my computer needs work. It’s just sus to me that the lag is circumstantial. It seems like if was a memory issue, it would be easier to trigger the lag or it would just be constant. The peculiar thing is that I cannot yet reproduce the problem. Something relating to my project seems to be a trigger.