Eliminating spaces between subdocuments in compile

I love the outlining power of Scrivener. However, I’m having trouble removing the evidence of my outlining process in the finished document.

I like to outline on a beat-by-beat basis, with each beat a subdocument, as follows (simple example).

  1. Mary sees the strange house at the top of the hill (Subdocument #1)
  2. Mary contemplates walking up to investigate (Subdocument #2)
  3. Mary decides to check it out and starts walking. (Subdocument #3)

When I compile the final text, Scrivener places a space (or other separator) between Subdocuments 1, 2, and 3. I want them to compile as one continuous document, with no spaces , so that the outlining process is invisible in the compiled text.

Does anyone know how to achieve this? Thanks.

Hi,

You’ll want to look at Compile formats - you’ll need to edit the format of your choice and make it so that the separators between these sections only use a single newline. To do this:

  1. In Compile, look at the section layout preview tiles in the central column. Above each one is listed which section types are affected. Look for the tile who’s section type name matches the section type for the documents you want to affect as listed in the contents on the right.

  2. Double-click on the section layout tile and choose to edit it (or duplicate and edit it). The Compile format editor will open with the relevant section layout selected.

  3. Switch to “Separators”.

  4. Change “Separator between sections” to “Single return”.

That should do the job.

All the best,
Keith

Thanks, Keith. I made a new format and messed around with it until I figured it out.

Although the problem this user has is slightly different, I was able to get started with the video below.

While the compile settings seem quite versatile, they are also the feature on version 3 that has the steepest learning curve, I believe.

youtube.com/watch?v=R1_6YaJRGzo

I’m sorry to hear you say that, as we put a tremendous amount of effort into trying to make it easier for users. It seems we failed. :frowning:

I’m glad you got up and running, though.

All the best,
Keith