Ellipses and auto-capitalisation

Okay, looks like the last post here was in 2006? PLEASE tell me some progress has been made on this?! This has been driving me slowly mad. Every time I use ellipsis points I get a cap after! Ugh! I don’t want a cap every time! In fact, most times I don’t!

PLEASE! Somebody fix this!!!

SUe Michele

What version are you using? This was fixed in v. 1.02 back in 2007. See

It’s worked 100% for me ever since.

It seems she’s on Windows - it may be a bug on that version. Sue, the post here pertained to the Mac version, which did indeed fix this issue four years ago. The Windows version is brand new and has only been available since November, so this needs reporting as a bug. I’ll point Lee, the Windows developer, to this thread.

All the best,

Phoo, now I can’t see who to thank, I think it was Keith, but yes, I’m on Windows. I did a search for “ellipses” and I guess I didn’t realize it was referring to Mac. But it’s still a problem for me in any case.

And not JUST with ellipses! Every time I type “U.S.” the next word is capped, whether it’s a new sentence or not! That’s GOTTA be a bug! Please help! I’m working on a big project for a client, and this is coming up a LOT. I can’t have that happen, and so far I’ve been able to catch it, but I’m not perfect. My client, thankfully, is not as nitpicky as I am, but still . . . this really, really, REALLY needs to be fixed.

I know that the Board Managers (or whatever you call them here) can generally shift things around and create new TOPics, when needed, from a post that needs to be someplace more appropriate (well, when I was an Asst. SysOp Way Back in the Day, I had the Power to do so, anyway), so by all means, feel free to shift my issue to wherever it’s more appropriate (just let me know where it goes!:). But this is a major issue, at least in MY universe, and I don’t really have time to figure out how to do that (assuming I, the end-user, even have the ability), as I must get back to what I call “400 pages of alien text” (points to anyone who gets that esoteric reference!) for my client.

So the essence of my post is, please fix this!

Thanks much for reading!

SUe, who’s thankful she’s actually getting paid for, you know, writing. :slight_smile:

Poof, you got it. Now the first part of the thread looks a little funny, but at least you’re in the Windows bug forum. :slight_smile:

I’ve got this on the bug list, but meanwhile, you can try a couple workarounds. If you don’t enter a space after the periods when creating an ellipsis, it won’t trigger the auto-capitalization. This should work for you whether or not you have substitutions set to replace a triple period with an ellipsis character (and that substitution doesn’t require a space at the end of the triple period, just to clarify; you can type “two…words” and it will become “two…words”). If you do want spaces between periods for you final output, it may still be less hassle for you to not type them when working and then run a find/replace to substitute " . . . " or "… " for “…”. (A replace after the fact won’t affect the capitalization of the following word.) You’ll just want to watch out during the replace phase for instances where you don’t need the space on the end.

Alternatively, you could just turn off the sentence auto-capitalization entirely in the Auto-Correction tab of Tools > Options… which might be the best solution for you right now to also avoid capitalization following U.S. and so forth.

I’ve had a similar problem, with abbreviations (like “etc.”) and also titles (“Mr.” “Mrs.” “Dr.” “Rev.”) and also military ranks (such as Lt. Cmdr.). Ranks and titles are usually okay, because most names are capitalised, but there’s always the odd case where someone’s surnames is de Walt or van Nieuwe or somesuch, or where I’m using the titles or ranks without a name following.

We have a list we can customize and add to for “Enable additional substitutions”; could we simply expand that list to do all the Autocapitalize options as well? So, maybe 4 columns: On/Off tickbox, Word, Replace with (where you could put in the capitalised version), and a tick box for “do/do not autocapitalize after period”?

Having a customisable list would help people control what they want to do, so some people could just turn the whole list off, or parts of it, and other people could add lots of extra words, if that’s what they want. And if we had the one list instead of the current three options, I think it would actually simplify Scrivener.

Admittedly, I’m suggesting this solution because I’m biased: I love Scrivener’s auto-substitute, since it allows me to correct my most common typos, and also auto-capitalize characters’ names and place names. :smiley:

It’s me again! I’m back because someone told me that this had been fixed, but it’s still there, even when I checked to make sure I had the most recent version ( - 13 August 2012), though perhaps it’s now an old version? Anyway, I’m going to turn off autocap function, assuming I find my way back to those instructions. This is still absolutely MADDENING!

I just wanted to check to see if it had been fixed yet!


By the way, just fyi, all the substitution stuff isn’t for me. I have to fix things as I go; going back would drive me just as mad as having to go and make the cap a lower-case letter.

I only hope that when this bug is fixed, it will follow the standard proper grammar, meaning, it will NOT cap after three periods (because that will be continuing the same sentence) and it WILL cap after four periods, because that is a trailing off of a thought that also ends the sentence. (I wouldn’t think this would be that difficult: 4=cap next letter, 3=do NOT cap next letter. But then, what do I know?)

I really have no idea how to resolve the problem where it caps after “U.S.” and other such abbreviations, but then, that’s why programmers get the big bucks, right? To figure out things like that!

[I wish the Kindle people were this easy to tell about glitches, though. If you have one, it’s funny to hear it’ do text-to-speech and hear how it says these words: Mr., Mrs., Dr., and Hmm. Try it!]


Hi Sue, this has been fixed in the beta build, so if you’d like to try it out, you can download that from the beta forum here. It doesn’t cap after three periods (or the ellipsis character) or after common abbreviations not typically followed by a capitalised word. (Dr. for example will still get an auto-cap after it, but given you’re presumably writing the good doctor’s name, that wouldn’t be incorrect.) Auto-capitalisation does kick in following four periods if you also have a space following them, so this…wouldn’t get one but this… Would.

Oh, wow! Thanks, Jennifer! Hey, quick question, though: everyone who has done an example here has used periods WITHOUT spaces in between them. I spent a semester at university having every single set of ellipses points corrected because I did that, but the prof (it was in a writing course, btw) kept circling them in extra-bold marker with a note that they have spaces in between! So it was thus drilled into my brain that way. So really I have two questions:

  1. Was all that for naught because the prof was incorrect and there are NO spaces in between? Or is that actually the way it’s supposed to be?
  2. If there are spaces in between, as I now do without thought, will this new fix in the beta version take care of ellipses done that way? Or only ones without spaces? Or both?

I have been much better off without the auto-cap, although I DO, indeed, miss it, since when I type fast I don’t always get the caps where they should be (my screen-name is SUe, that pretty much says it all:). But if this is only going to correct ellipses without spaces, I might as well just leave it that way, because I’ve been doing it so long I will go nuts if I have to re-learn it in the middle of this novel. (I suppose I’d have to re-learn it eventually, but not while I’m in the middle of a novel!)

I have to say, though, that all things considered, if this is the biggest problem I have with Scrivener, it’s a pretty darn good program! (Now, if only someone could mind-meld with me and implant their understanding of how compilation works, as I don’t know if I will ever master that. But I do know that it gets it turned into something I can read on my Kindle, which is half the battle. When I finally get ready to publish, I’ll have to do some trial and error on which stuff is included and which isn’t, and I’ll probably post a bunch of questions about that when I get there. But in the meantime, I need to re-read what I have thus far, as I cannot for the life of me recall everything at this point! But I digress. Often.:slight_smile: )

Anyway, thanks much for the reply! It’s nice I’m not alone!

Oh! BTW, is there a Lit-n-Lat IRC chat, by any chance? I’d love to hang out there, if there is!

Thanks again,


Spaces or no spaces is a style thing, like whether lists should have a . or a ) after the numeral, and one that I think should be left up to the final stage. It’s easy enough to change an ellipses character (or 3 dots if you don’t use the character) to “. . .” with global search and replace, if it is required to do so. I would do it in the compiler’s Replacement pane.

Hi Amber!

Long time no see!

So, if I stick with my " . . . " or “. . . .” I’m okay, then? (The only way way this could’ve been instilled into my brain with more effectiveness is if I’d had a nun thwack me over my knuckles with a yard stick!)

BTW, I’ve never even HEARD of an “eliipsis character”! Where does one find such a thing?

If that’s what’s been done in the beta, then I might just try to see if it works okay for me!


Spacing out the periods for the ellipsis will still trigger the auto-capitalisation even in the beta, I’m afraid; we’ll keep it on the list to see if it can be worked around. The spaced out periods are, or were, the preferred method for some citation styles–MLA is this way, I don’t know off-hand about others–so they’re not incorrect, but I don’t believe they are as frequently seen in publications and fiction writing. These days most word processors have a substitution in effect to swap three unspaced periods for the ellipsis character, if such exists in the font being used–Word will do this by default, for instance, and so will Scrivener, though you can change that behaviour in Options. You can enter the ellipsis character manually using the Alt+0133 code (just hold the Alt key and type out the numeric code on the numpad).

What Ioa was suggesting is using three unspaced periods/the ellipsis mark (which will be automatically replaced with the default settings, so you wouldn’t need to hit the Alt code all the time!) when writing, then, if your style guidelines require it, use the compile Replacements to swap in three spaced periods for the ellipsis mark. That makes it easy to adjust the formatting per specific requirements. It would mean though getting into the habit of not spacing out the periods when you type.

Here we are in 2015 and this bug is still here. Why can’t we get this fixed? (Atlantis doesn’t do it.)

I think part of the problem is that not enough importance has been put to it because there can be a “workaround,” or because it’s thought that an ellipsis should be used instead.

Neither of these answers are satisfactory because at least in the U.S., one must use three dots separated by spaces, with a space at each end, in standard manuscript format. A manuscript does not contain ellipses. You’ve managed to fix it with respect to initials, can’t we get it fixed with respect to three dots?

I hate replying to old threads, but this is the only one that contains the problem I’m experiencing.

I’m on Windows, v1.9.7 (no updates since 2016), and this is still an issue when using manuscript formatting of ellipses, which is a space to start, three periods (with spaces in between) and a space on the end. Every time, this auto-capitalizes the following word, which is incorrect.

I don’t want to turn off a feature (fix sentence capitalization) just to correct a bug, but it’s hell having to go back and revise those capitals.

Will this be addressed in the upcoming Windows v3 (whenever that happens)?