Em dash

I have just transitioned to ver 2.0 of Scrivener from the prior version and have noticed that I can no longer create an em-dash by quickly typing a double hyphen. I have checked the appropriate box in the preferences pane but to no avail.

P.S. the em-dash eventually appeared but there was a significant delay as compared to the prior version where it appeared immediately. :question:

Please advise,

This whole system of typing one character to mean another has gotten too baroque. I hate typing (a), (b), then © and suddenly seeing a © character!

However, one place you can set this preference is in System Preferences:Language & Text:Text. Another place is in your compile settings. Probably there is a setting in Scrivener Preferences too.

Me, I just type an m-dash (or n-dash if that is what I want).


Scrivener now uses OS X’s standard text replacement system (previously it did its own replacements, but some of them caused problems when typing in other languages).

So blame Apple for the new system, not me. :slight_smile: On the plus side it does mean that you now have full access to Snow Leopard’s auto-replacements system, which wasn’t possible before. The behaviour is now consistent with other apps.

Understood and thank you for your reply.
Scrivener 2.0 is fantastic!

Thank you! Much appreciated!

I can get Scrivener for an em dash from a double hyphen, but when I export my document to Word, it reverts to a double hyphen. Anyway to fix this? (I am using Scrivener 1.54)

In your Compile Draft settings under Text Options, uncheck the box in Manuscript Style in the upper right to “convert em-dashes to double hyphens.”

Thank you!

I know it’s an old thread, but my – to — replacement died during a few weeks ago, I never bothered investigating it, but I’m since added it back into the language and text settings in Lion.


The replacements are now instantaneous, much quicker than on SL. Another +1 for Lion.

Just for info.