em dashes and "smart" quotes

Every time I close a quote after an em dash Scrivener picks the opening quote rather than the closing quote. Which means I have to copy and paste over a closing quote from somewhere else in the chapter in order to get it right.

It’s getting old.



Scrivener uses the OS X text system which handles this. I believe the trouble is that the software has to make an educated guess about which form of quote is the best to use, and it doesn’t have a full overview or understanding of the text as humans do, instead using a set of rules to determine whether this or that character should normally have an opening or closing quote after it (because scanning back through the text and matching up the number of quotes would slow down typing). That’s my assumption, anyway - as I say, this part is actually handled by Apple code rather than by any algorithms of my own, but I doubt switching over to my own code for this would be any better as there will always be situations where “smart” features aren’t so smart and don’t result in what the user intended. But you’ll see exactly the same behaviour when it comes to em-dashes and smart quotes in most word processors, including Pages and Word. I have long been in the habit of typing an extra letter after the em-dash and before the quote, and then deleting the extra character once the quote is in place - I got into this habit about fifteen or so years ago, from using Word, and don’t even notice I’m doing it any more, so this is something that has been a limitation of smart quotes in word processors for many years (so it’s getting older than you think :slight_smile: ).

In Sys Prefs > Keyboard > Text:

em dash opening quote

em dash closing quote

The system will then autocorrect it as you want.

You beat me to it Briar Kit! :smiley:

And remember you can type an opening single-quote with opt-], closing single-quote with shift-opt-], and opening double-quote with opt-[ and closing double-quote with shift-opt-[

Huh, why didn’t I think of using system replacements for this? Genius!

Is there some trick to making this work reliably?

I made the changes in the System Prefs using copy+paste. It works half the time, so I thought I’d use the shift + option to get the open&close smart quotes and em-dash in the System Prefs.

Now, it’s not working at all, not even in TextEdit, which is odd. I’ll reboot and see if that helps.

Mac 10.8.5
Scriv 2.5

As the helpful posting (below) notes, the Apple OS interprets a single-quote/apostrophe after a space and before a letter as an open-quote. Is there any way to mass convert/mass preserve formatting (as in Formatting/Preserve Formatting)? If not, is there any way to add such a function, given the Apple interface?