Embedded image Scrivener to .docx to Scrivener - missing image then tried .rtf import

Within my thesis draft in Scrivener, I have embedded images. My workflow involves compiling to Word (.docx), with images and styles intact. I can then create tables of contents (sections, figures and tables) using Word and then update reference lists using Endnote, all within Word and the .docx file.
I then gather supervisor feedback (tracked changes and comments in Word). I accept or reject tracked changes and retain the comments.
I import the .docx file back to in Scrivener. All is OK ( a few tweaks in my process later), EXCEPT that the images are missing. I have tried importing in to the draft folder or elsewhere. There is no difference.
So then I thought to try .rtf, based on comments here about the differences. Using .rtf as a source worked for the images, except I then had some paragraphs that correctly retained double spacing (from Scrivener to .docx to .rtf to Scrivener) and some that during the last step importing process (using .rtf) changed to single spaced paragraphs. I thought that it might be due to some paragraphs having embedded comments, but that didn’t seem to be the issue.
NB: the paragraphs are [normal] style in Word [double spaced] and [No Style] in Scrivener.
Any thought/suggestions on how to address that last step formatting issue when using .rtf as a source?

There must be a difference between the paragraphs, either an applied style or specific formatting inside the rogue paragraphs… In my case it was a forgotten Style.

Thanks @AntoniDol that is what I would have assumed. However, given that the document imports with correct line spacing using .docx format, but sometimes incorrect line spacing when using .rtf for the same file AND with the style normal (or no style from/to Scrivener), I needed to look further than just the paragraph.
What I found is that it is due (at least sometimes) to the presence of a comment in the preceeding paragraph. When the comment is there during .rtf import, the subsequent pargaraphs with no comments have single line spacing.
When I delete the comment in Word and re import (both using the .rtf option), the line spacing is correctly double.
Microsoft Word (with comment, .rtf file)

Scrivener (imported .rtf with comment)

Scrivener (imported .rtf without comment)

So, it appears that it is the presence of a comment in the .rtf version of the file that is causing the issue for me. This is possibly a bug (due to the difference in .rtf and .docx treatment), but for me it means I will need to change my workflow to compensate. I can not apply a global double space in Scrivener, because that affects other formatting.

Good call! Hope you find a solution…

When I import in this way, all my previous files are merged (which I can live with, as the styles remain) and I lose some calculation abilities (such as compilable calculated fields <$n:chapter>.<$n:section>). I need to develop a strategy for covering that issue, but it may become less important as my document nears completion (less structural change).
I have found that using [Documents] [Convert][Text to Default Foratting] takes care of the line spacing issue, as the styles keep everything else in order.
So, the remaining issue is to find a way to replace compiled heading numbering with the original field codes, or make manual numbering adjustments when needed.

If I split the .docx file (with tracked changes and comments) using the Word function for that purpose and save the splits in .rtf format, I have nice bite sized chunks to merge back in to Scrivener (with embedded comments, tables and images), along with file names in a form that simplifies that process. See this Youtube for splitting the file: …split Word document…. I can then open two quick reference windows (showing comments) in order to update the section/sub section I am working on.
This adaptation means that I am not as concerned for now, with the loss of the calculated fields.
I have been using Scrivener for quite some time. I am still SO impressed with the power that I have hardly tapped in to, that is both in the software and the support and development efforts of people (paid or otherwise) in this community. Thank you to everyone. :grinning: