Ending quotation mark, wrong line break

I use European (German) quotation marks, instead of “English” (upper66–upper99), they go „like this“ (lower99-upper66). If a direct speach ends with a comma, the ending quotation mark goes to a new line.

Correct formatting:

„What a nice day,“
said Mary.

Scrivener formatting:

„What a nice day,
“ said Mary.

Scrivener v3.2 (14272), MacOS 11.0.1 (BigSur)

Scrivener uses the text engine supplied by Apple. The same text engine is used by TextEdit. I see the issue in Scrivener and TextEdit, which suggests this is an Apple issue.

A workaround:

  1. Insert > break > word joiner. Use this between the comma and closing speech mark to keep the two characters together.

  2. In system preferences, you can create a shortcut for this menu item. I use CTRL J.

support.apple.com/guide/mac-hel … lp2271/mac

When writing, you can then easily type the word joiner where necessary.

  1. You could do a search and replace to fix this throughout your manuscript, searching for:

comma closing speech mark

Replacing with:

comma word joiner closing speech mark

To type the word joiner in the replacement box, add the option key to your chosen keystroke. For example, I would type CTRL OPT J.

If that doesn’t work, you could use the menu command (with a mouse or trackpad, as usual), or you could copy and paste from the editor to the replacement field.

Of course, this shouldn’t be necessary, but it should help until Apple fixes the issue.