Endnotes not showing up in MMD->RTF

Hello all,

I have a document with inline footnotes. I’m compiling from MMD to RTF. The superscript footnote number does not show up in the body, and the end of the document shows a [^fn1]: sometext , which is of course the unformatted markdown.

I’m calling these footnotes, but what I really want are endnotes. What am I doing wrong?

I apologize if this has already been covered. I searched the forums and did not see this exact issue.

Thanks!
Dave L

It’s a good idea to test other output methods if you come across something like this, particularly if it looks like a syntax problem where raw code is coming through. Try HTML and see if that works (they’ll be endnotes of course, as HTML has no pagination), and plain MMD to see if anything looks messed up in the output file.

Thanks for your response, Amber. I’m getting interesting results with different outputs. Testing with both inline and inspector footnotes. The “Remove Footnotes” box is not checked. “Export inline footnotes as endnotes” is checked.

  • If I compile to HTML, then the notes *do appear in the output.
  • If I compile to MMD–>RTF, then the notes do not appear.
  • If I compile to RTF (without markdown), then the notes do not appear.
  • If I compile to MS Word 97-2004, then the notes do appear. This is interesting because I thought the documentation said that this is actually the same formatting as RTF.

I think for now I will just compile to MS Word 97-2004 and forget about the markdown. Let me know if there are other tests I could run. I will experiment more with MMD once I get more used to Scrivener.

Dave L

As an aside, one issue you might be having with RTF files in general is loading them in an editor that can’t read footnotes. Are you using something like TextEdit to preview them?

But on your main point, I have come across a scenario where something like what you describe happens and I haven’t narrowed down yet why. If I make a new blank document with some filler text and drop a few inline footnote ranges into it, it compiles correctly. However in another project I have, when I compile the footnote content doesn’t get appended to the bottom of the MMD file, so the markers just stay in the text. Is that what you are seeing? If so, are you using MMD3?

In the above example I used both MS Word and TextEdit. They looked the same.

If I make a blank document with original compile settings and add some inline and inspector footnotes, then the footnotes show up fine in both MS Word and RTF. Is something from the MLA template, which wants to put footnotes as endnotes (ultimately the way I want to go), messing things up?

I believe I am using MMD2. I’m not sure how to check easily. Should I reinstall? Should I download the newest version of MMD 3.5 or choose MMD 3.0?

Hmm, well the MLA template was never designed with MMD in mind, however I can’t think of anything that would cause footnotes to break. What does the MMD file look like if you just use the regular MultiMarkdown output, rather than using one of the formatters? Does it have the footnote content at the bottom of the text document?

But do note that the MLA template was designed to group notes together between “Endnotes” and “Works Cited”, in accordance with that style guide. If you click on the “Endnotes” item in the draft, you should see instructions pertaining to this.

If you never installed your own version of MMD, then it’s probably 2.4, the embedded version in Scrivener. I wouldn’t bother with updating just yet. We’re coming out with an update that includes MMD3 soon, and right now it’s a bit of a learning process to get Scrivener working with MMD3.

I might just move my file over to a plain template.

Yes, it has the footnote content at the bottom and the references in the body. But when I pop it into nvAlt, the footnotes show up as raw text and not formatted. I wonder if there is some whitespace causing problems, because much of the text formats as plain text “code.”

Got it. That is the behavior I was expecting.

Thanks again for your follow up, Amber

It does sound like it. There is an option in the Transformations compile option pane which can convert whitespace to literal characters. So an indented paragraph would have spaces prefixed in front of it, or line-spacing between paragraphs would become carriage returns. If that is on, and you are using MMD, it could cause all of the paragraphs to turn into code blocks, since the “syntax” for that is 5+ spaces in front of the line or a tab. If the footnote content is offset by whitespace, they would no longer be footnotes.

Maybe, but a Scrivener project is pretty flexible, so taking a step that drastic wouldn’t ordinarily be as beneficial as making a few tweaks. For instance, you could probably change more just by setting your compile Format As option to “Original”. That’s the stock vanilla setting and is thus easiest to build up a format from. The one that comes with MLA is finely tuned for producing a rich text MLA document.

Try setting it to Original, change the output mode to MMD->RTF, and see if that works better?

Ioa, you may want to make the switch to a new UID for the forums. Not just because I am still bitter over Ioa-iffer-gate, I still am thank you for asking, but simply so folks stop calling you Amber. Unlike Capt. Kevin, this one is really an understandable mistake.

What?! When I’m so close to 10,000 posts?

You “could” just go into the DB and change your handle to “Ioa-iffer” :stuck_out_tongue:

Alternately you could consider: Ioa – Formerly know as AmberV

But if he changes from AmberV to Ioaiffer, then everyone will want to change their handles, myself included. It’ll be anarchy!

I want a cooler handle, like Nom, or Vic-K… do you really want to encourage this kind of behavior!? :open_mouth:

Consider who you are typing too.

I started a new blank project, removed the whitespace, and compiled MMD–>RTF using Original settings. I opened the document in MS Word. My inspector footnotes showed up as endnotes (which is fine), but without footnote numbers.

Sorry for the name mixup, Ioa. I’m especially ashamed because I have been following your posts for a while.

Dave

Heh, I’m cool. 8)

Ha, don’t worry about. I didn’t even notice.

Is this project something you wouldn’t mind us having a look at? If that’s okay with you, zip up a copy of the project and send it to mac.support AT literatureandlatte DOT com, “attn: Ioa” in the subject. It’s probably something I can more easily spot if I’m looking at it.