Enforced Formatting

I love Scrivener but consistently keep having issues with formatting, having made multiple forum posts on the matter I thought it was just my ignorance of the program… however I have come to the conclusion that is simply not the case, but rather, that an extra feature would be required to satisfy how I use Scrivener.

I use Scrivener to write blogs and articles for web-sites and so eventually use the generated text in my HTML, thus I do not require any special formatting to be carried through to my HTML, but I do require a visual formatting that is easy on the eye whilst composing my articles, with the high resolution of my screen I prefer courier 18 with no carriage returns between lines (gaps between paragraphs unless I hit return twice).

Having set the global preferences to my required formatting I hopefully soldier on. However, I copy and paste rather allot of text from multiple sources and although I mostly remember to use the fist-full of fingers required to paste the newly required text to match my documents formatting… at times I forget. At such times I’m then required to delete the offending text with it’s undesired formatting, however, I soon discover that I can not directly paste into the now empty area as it somehow retains the formatting of the previously wrongly formatted text, so even when using the key combination it still retains the undesired formatting. I’m now required to delete that area or at least move above it to use the special combination to paste the documents set formatting!

On occasion, when in a rush or on a roll I sometime discover much later that somewhere along the line I have pasted incorrectly and now have a document full of various formatting with the very frustrating carriage returns between text/paragraphs which I so hate!

Thinking I have done something wrong in the preference pane I go back and mess with the preferences once again, that is the Global preferences, the documents preferences and the preference bar at the top of each page etc… Frustrated and with the flow of my work yet again interrupted I throw my hands in the air in total despair.

I’ve come to the point of total frustration, every time I try to work I spend half an hour or so trying to resolve this issue but eventually give-up and and resign myself to battling through correcting formatting as and when necessary, it is really breaking my concentration and the flow of my work to the point that I wonder if I should move on to another program. Silly as it may sound I’m beginning to feel stressed and worked-up just thinking about using Scrivener… wondering if and when the issue will pop up again, and inevitably it always does. Today is yet another day when my early attempts to writing have been thwarted.

If I could simply have a preference button that I could set my desired preferences to, which when turned on would override ‘everything’, no matter what (pasting, global, document or whatever other preferences there maybe… that would be truly fantastic.

I love the features and organisation tools of Scrivener… it truly towers above any other program I have come across, but this one issue is making life impossible, I just can not work with text with multiple formatting and the dreaded enforced gaps breaking-up related text.

In Christ, Karl.

How about using the system short-cut settings to swap round “Paste” and “Paste and Match Style” so that Cmd-P gives you the latter, and the “fistful of fingers” gives you the ordinary paste if you need it? Then get to know “Convert : Formatting to Default Text Style” for the times when you use the wrong one. I’ve set up a shortcut key for that too …

:slight_smile:

Mark

Thanks for the idea Mark.
I guess when you say “System short cut settings” you mean the settings to my machine and not Scrivener? I found the place on my Mac for key shortcuts but can not locate one for paste, I added one dedicated to Scrivener but couldn’t see how to link it to the ‘paste’ function only that I could assign it the cmd+V keystroke which are ‘paste’ on a Mac.

I’m not really sure that this is the best way to go about this though as if I find in the future that another program wants to revert to the normal function I maybe find myself frustrated because I’ve forgotten that I had changed the system setting.

Mark, that ‘convert formatting’ could come in handy, I’m a bit reluctant to try it on this ongoing document, what does it do? Convert everything or just the document I am on? Also which formatting will it revert to, the ‘Scrivener Global’ or just the documents or the files. It isn’t instant on my Mac as a box appears asking me to tick various boxes.

Appreciated.
In Christ, Karl.

In the keyboard shortcut pane, when you click the + button a dialog comes up, which allows you to set which application the shortcut will apply to, so you can set it up to work in Scrivener only, by selecting that from the dropdown at the top of the little pane. Or you can set it globally so that it will work in all applications. I set it for Scrivener and for Nisus Writer Pro, the two apps in which it really matters for me … though NWP has it’s own keyboard shortcut system in its own preferences. That one is brilliant as you can set multi-letter shortcuts, so for me Cmd-BB is black text, Cmd-BL is blue text … Maybe for version 3 Keith?
As for the , that only affects selected documents, so if you only have one document selected in the binder, it will only affect that one. If you want to do a whole bunch of documents at the same time, you should select them all in the binder and then call up the menu — or key-press for me. It brings up a little dialog in which you can limit how much gets changed; if you don’t tick any of the boxes, the document will be converted to the style you have set up in the Scrivener preferences “Formatting” pane.
I’m using that the whole time, as my work requires me to import a lot of files to edit, created by colleagues using Word for Chinese Windows and I need them to appear in the font and size I like working with … not something like TNR 10.5 point! So for me, it’s import and select document, press Ctrl-Cmd F, take snapshot then start editing.
:slight_smile:
Mark

Thanks Mark.
I did as you said, added a shortcut for Scrivenrer, called it ‘paste’ and added a shortcut key combination. However, unfortunately it does nothing and I can not understand how it can as isn’t in anyway associated with any action such ‘paste’. How then do I associated my key combination with an action and so make cmd+v behave as cmd+alt+v does in Scrivener? Sorry, I must be missing something rather obvious.

Anyway, everything was going rather well this morning after my initial ‘bad start’. I was being extra careful about using the triple combination to paste, I’d just copied a Scripture from a Bible program running in Parallels which, although not copied by myself adds the Scriptural reference two lines above the text when I pasted.
I am certain that I hadn’t paste it wrong but then suddenly I couldn’t delete the gap as usual between the reference text and the text itself, I undone the paste but found that not only was the same undesirable issue in place where and below where I had pasted but also was in place the above existing body of text, not that the formatting had changed but that if I pressed ‘return’ mid-sentance in any of my existing text it cleared two rows when earlier would simply drop to the next row beneath as I desired!!! Unless I’m completely mistaken it seems that the format of my copied text seemed to affect the format of my existing text even before I’d pasted it, though I guess I’m just become hysterical :laughing:.

Anyway, thinking “here we go again” I threw caution to the wind and tried the 'convert > formatting to default text" and it worked a treat, though going through the menus to locate it and dealing with the dialog box is rather bothersome, but at least thanks to you I now know it is there.

This really is becoming quite a battle to write though, I’ve accomplished little today once again. To be able to just get on and write would be such a blessing.

Thanks again Mark.

In Christ, Karl.

I did a little search, and there are problems with swapping the paste-and-match-style combo with the paste keyboard shortcut: if you use the match-style version on an image, nothing will happen.

Instead, you may want to attempt a simpler version of paste-and-match-style, such as CMD-OPT-V, or even CMD-CTRL-OPT-V, which on apple keyboards are all in a line (except for the V of course).

As for the ability to convert already pasted text to the default style, I believe you can do that on any highlighted text, so you don’t have to click on the binder when you accidentally do a standard paste.

One last suggestion: For the purposes of your writing flow, you might consider putting your pasted material into separate documents from your own writing. You would then use Edit Scrivenings to view these “clippings” in line with your own words before and after the quoted material. Assuming you can leave the pasted material alone, this method would save you a lot of headache.

I tried ‘ctrl+alt+cmd+V’ and ‘alt+cmd+V’ but neither of these would paste, only shift+alt+cmd+V or cmd+V seem to work.

That is good new, I looked to see if I could find a button in ‘customise toolbar’ to save me going through the menu bar each time but to no avail.

I’ve resorted to that before but decided that if I’d got to go to those lengths that I may as well use text-edit to do my work! :smiley:

It looks as though there is no answer and I think I’m going to have to see if I can ‘shut-up and put-up’ or move on to another program. Such a shame as it is such a great program apart from this formatting issue which I find a constant aggravation. But for all the trouble Scrivener saves me this is causing me almost as much. I’ll just have to see if I can but up with it and try to put it out of my mind. I think I’ve got myself so worked-up about it that when it happens I spit out my dummy and throw my rattle out of my pram! :smiley:

Thanks for all the advice.
In Christ, Karl.

You’ll find the same issues in text edit, I’ll wager. Most editors on the Mac support rich text.

I noticed earlier that for your custom shortcut you said you used “paste”. CaPitAlizaTioN matters a lot here. Your Scrivener short-cut should look something like this:

Scrivener
Paste [key-combo goes here…]
Paste and Match Style [key-combo]

Note that the “Paste” has to be capitalized exactly as it appears in the Scrivener Edit menu, as does the “Paste and Match Style” shortcut. If you’re off by a single capital/lower-case letter, or even have an extra space, the replacement shortcuts probably won’t work.

If that doesn’t work for you, then I’m all out of ideas.

Hey, thanks Robert.
I’ve set it up and it works fine, I’ll see just how I get on with it tomorrow when I start writing again. I’ve just got to work out why to get rid if the indent at the start of each paragraph and then it’ll be plain sailing as long as there are no other issues.

  Any    ideas

how to get rid
of that first line
indent? :smiley:

Thanks for all the help… I was at my wits end.
In Christ Jesus, Karl.

Make sure that your default text preferences are set how you want them in Scrivener>Preferences>Formatting. You can adjust the indentation there. That’s global (for all projects); you can also change the settings on a per-project basis with Project>Text Preferences.

In each case, that will affect new documents created; you can use the Documents>Convert>Formatting to Default Text Style to adjust any already extant documents. If you want to get a hang on how that works, I suggest making a test project and just messing around with the formatting, copying and pasting from external sources, etc. and converting. It’s an excellent tool. Also keep in mind, as I think Mark said near the top of this thread, you can set up a keyboard shortcut for that so it’s easy to apply whenever you need it. If you have the document open in the editor, all you need is to be focused in the editor; you don’t have to select text at all. It applies at a document level. (Keep in mind however that if you have multiple documents open in a Scrivening session and use the convert, it will convert all the open documents there.)

Also, hopefully now that you’ve got the keyboard shortcuts for Paste and Paste and Match Style set this won’t be an issue, but if you use “undo” (cmd-z) after a wrong paste it will clear the paste and not keep the pasted formatting, so you can do the proper “Paste and Match Style” at that point and get the proper formatting. Just highlighting and deleting the text, as you’ve found, does not strip the unwanted pasted formatting.

Got there but I can not see how to get rid of the indent, the indent only effects the very first line of a paragraph, nothing else.

A shortcut to run the convert would be great too, I’ll set that up in the morning. :smiley: .

Thanks again for all the help, this has been a real issue for me from day one, but hopefully it is going to be a thing of the past.

Thanks again.
In Christ, Karl.

Might be we’re talking about different things using the word “indent.” First, for the formatting, you should see two sliders, one of which will affect the first line indent and the other of which will affect the rest of the paragraph. Move both to the left if you want no indent (hanging or regular):

indents.jpg

Also remember that this will only affect new documents, so you’ll need to use the Document>Convert>Formatting to Default Text Style to fix any pre-existing documents.

If what you mean is the margin in the editor–that there’s too much white space around your text when you’re viewing it in the editing pane–you can adjust that in Scrivener>Preferences>Editor with the Margin settings (separate for Wrap to Editor mode and Wrap to Page). Smaller numbers there will mean less padding between your text and the edges of the editor window. You can set the margins also for full screen in the Full Screen tab under Preferences.

For the indenting, you might also like to turn on to see if there’s a tab character in there that you need to remove.

:slight_smile:

Mark

http://grab.by/7uCw

OK, above is a link to a snapshot I took. You can see clearly on the right of the snapshot that I have the preferences set for no indent, I have also run ‘convert’ several times yet it hasn’t formatted my text as desired. However, the text that starts “TVs Super Heros” I typed in, although the whole block is indented at least the first line isn’t indented further than the rest of the text which is much better.

However, although my preferences are as I wish and I have run ‘convert’ several times when I paste into the document it still indents the first line. The bottom text starting “If what you mean…” I copied from a post on this page (above) and pasted into my Scrivener document, as you can see, it still indented the first line. :cry:

What am I still doing wrong? I’m obviously missing something real simple somewhere. Convert seems to totally ignore my preferences concerning indent.

In Christ, Karl.

Look at Project>Text Preferences… and make sure you don’t have it set to override text formatting. If you want to use different settings for a particular project, this is a great way to do so, but obviously then you’d want to make sure it’s set up for the preferences you want! I notice the default font and your actual font are also different in the screenshot, so it seems likely this is the problem. If it’s set to override the formatting for that project, then the Convert function will use that as the desired formatting, rather than your global preference.

Yes, I’m there! :smiley:

Everything is just as I want it! Thank you all so much for all of your help, there’s no way I would’ve sussed that out on my own. Odd really as I use allot of software packages and in 90% of cases I’m self taught. I think it might be having all those font options and paste issues resolved in so many different location that through me.

There is something I want to investigate about when I export to HTML but I’ll start a new thread for that when I export this document.

Once again, thank you for all of your time and assistance, invaluable.
In Christ, Karl.