ePub colors: span style="color: #000000"

As I inspect the ePub output, I see every paragraph has a span that colors it black:

<p><span style="color: #000000">

Is this necessary? Can I tell Scrivener to not inject that span tag?

This isn’t happening in my ePub3 output. I suggest that your formatting may have “black” formally assigned to much of the text, instead of letting the colour be automatic. Not being able to see your compile setup, :smiley: I suggest the following troubleshooting process:

  1. In Scrivener Preferences, go to Editor > Formatting. (if you use different default formatting for each project, substitute “Project Settings… > Formatting”)
  2. Right-click in the text preview area
  3. From the contextual menu, select Text Color > Remove Color.
  4. Select the documents that produce the offending “span” commands, and use Documents > Convert Text to Default Formatting to blast blackness from your documents.

If that doesn’t work, you’ve probably got text forced to black instead of automatic inside your compile format. So, you’ll need to edit your compile format.

  1. Open your compile format for editing.
  2. Click on “CSS” in the right-hand column
  3. Right-click in the text preview area for Default Paragraph Formatting
  4. From the contextual menu, select Text Color > Remove Color.

One of the above should work. If not, it’s beyond my experience, and we’ll have to hope someone from tech support steps in… :wink:

Thank you Silverdragon, I keep learning new things about this app with every one of your posts.

Sadly though, those blacks are still there. I’m gonna chalk it up to user error. I’ll play around more later.

  1. I read the beta release notes, some nice improvements KB!
  2. dowloaded beta
  3. found this styling setting and changed it from embedded to inline CSS
    prefs.png
  4. compiled, and spans are now gone. I think it was step 3

I doubt it was that, since that setting doesn’t affect compile. More likely one of the numerous fixes in the beta (which I’m using) fixed the spans.

Glad it’s sorted!

Back in July - so for 3.1 - I added a check that doesn’t include span styles for black text, so this should be fixed - which is hopefully why you are not seeing it in the beta.

All the best,
Keith