ePub double spacing between paragraphs

When I export to an ePub I am getting double spaces appearing between my paragraphs. How do I make that go away?

Formatting is often controlled in the Formatting compile option pane (crazily enough). If you check in there, is “Override text and notes formatting” is enabled. If so, one of the formatting rules in the list in the upper half is likely adding paragraph spacing. Flip through any that have a checkmark in the “Text” column and verify the formatting in the lower half of the pane.

If the override checkbox is disabled, or you don’t see any double-spacing in the Formatting pane, then it must be coming from some place else. The first thing I would check is loading my ePub file in another reader to see if the effect is caused by the reader’s default output.