epub file has extra line space between paragraphs

I’ve looked through the forum posts and on other sites including PubIt, and I just can’t seem to figure out why the epub compiled book files I publish and read on my Nook Tablet have an extra line space between paragraphs. This problem is not appearing either in Preview on the PubIt site–my dashboard, or on the Nook for Mac application, so right now it appears to be a device-specific issue.

In Formatting we are using the line and paragraph spacing defaults. We have Paragraph spacing set in Compile at the before and after default of 0.0 points. I haven’t yet tried experimenting with changing that yet as we want to decrease the spacing not increase it and the only setting change there is to increase paragraph spacing. There may something there though.

Someone on this forum recommended changing the line-height multiple in the spacing options to 2.0 and then changing the inter-line spacing to 1.0. But that appeared to solve a problem where line spacing could not be changed on the Nook reader itself. I went ahead and tried it and although it looks wrong in the editor (like super-spaced), it looks great when compiled. Unfortunately, it looked great in the Nook for Mac application, but when I loaded the epub file on my Nook Tablet, the extra line space between paragraphs was still there. What is strange is that some of my epub-compiled books look fine on the Nook and others do not. I’ve tried comparing Compile settings for different books but to now avail.

What’s bizarre is that on the Nook Tablet, selecting Publisher Defaults makes the spacing issue go away. Turning it off brings it back. I don’t think there is a paragraph spacing control on the Nook Tablet that could be causing this.

Thanks in advance to anyone who has an idea of how to fix this bug a boo.

***After posting this I just now found that in the problematic book scriv file, when I looked at the paragraph spacing for the text in the editor, that there was a Paragraph spacing after setting value of 12.0 points. However, I tried changing that to 0.0 points and that did not solve the problem.

This spacing was coming through the compiler even though you had Formatting set up with a text override and 0.0pts of before/after paragraph spacing?

I set the Paragraph spacing after to 0.0 points and made sure the Compile setting was also 0.0, and the problem on the Nook Tablet remained. I can’t say with certainty this is the source of the problem. Thank you

Okay thanks. I just acquired a Nook for testing, and will be checking out a number of things with it, so I’ve added this thread to the list.

Great, I appreciate you taking a look. The issue could be device specific (the Nook Tablet) or even common to all the Nook devices and perhaps could lie in the CSS that Scrivener generates for the epub file and the way that is read by the Nook. Looking forward to any illumination you can shed on the topic. Thanks again.

A new wrinkle. I ran the file through Calibre in a special application on my host server and when I downloaded the epub file onto my Nook, wonder of wonders–no extra line space between paragraphs. This doesn’t solve the problem but it does present a new question as to why the compiled file direct from Scrivener has the extra line space but if the compiled file is run through my Calibre-based application–no line space.

When you say you ran the file through Calibre, what all does that entail? I’m assuming you did some kind of import and export procedure? If so, what settings were you using in the export window—particularly in any of Calibre’s panes that involve format cleaning?

Also, would you mind sending a copy of .epub A and B, where A is the compiled copy and B is the Calibre processed copy, to mac.suppport AT literatureandlatte DOT com? That would help a lot as I could compare the code level changes. Just send it ATTN: Ioa in the subject so that whoever picks it up knows who the files are for, and link back to this thread URL.

I am sending off the files as you requested. Thank you