error downloading update?

I’m getting an error when downloading the update:

I’m trying to update from 1.9.13.0 to 1.9.14.0. Specifically the critical hotfix.

I get this message the moment I hit the download button.

Is there any other place I can download this critical hotfix?